summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-06-03 16:57:24 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-06-03 16:57:24 +0000
commit8b42f033c87eb0d12104e1f3fdb91023ca6cf1c5 (patch)
tree496efe7aa0a36f1352a088a0d16729840d57dc4a /net-p2p/amule
parentInherit user.eclass for enewuser (diff)
downloadgentoo-2-8b42f033c87eb0d12104e1f3fdb91023ca6cf1c5.tar.gz
gentoo-2-8b42f033c87eb0d12104e1f3fdb91023ca6cf1c5.tar.bz2
gentoo-2-8b42f033c87eb0d12104e1f3fdb91023ca6cf1c5.zip
alpha stable wrt #413129, remove old
(Portage version: 2.1.10.53/cvs/Linux ia64)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog6
-rw-r--r--net-p2p/amule/amule-2.2.6.ebuild111
-rw-r--r--net-p2p/amule/amule-2.3.1.ebuild4
-rw-r--r--net-p2p/amule/files/amule-2.2.6-gcc45.patch22
4 files changed, 7 insertions, 136 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 71a934f0ad93..142b205e19ce 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/amule
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.166 2012/05/21 12:25:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.167 2012/06/03 16:57:23 armin76 Exp $
+
+ 03 Jun 2012; Raúl Porcel <armin76@gentoo.org> -amule-2.2.6.ebuild,
+ -files/amule-2.2.6-gcc45.patch, amule-2.3.1.ebuild:
+ alpha stable wrt #413129, remove old
21 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> amule-2.3.1.ebuild:
x86 stable wrt bug #413129
diff --git a/net-p2p/amule/amule-2.2.6.ebuild b/net-p2p/amule/amule-2.2.6.ebuild
deleted file mode 100644
index 3104033f47ce..000000000000
--- a/net-p2p/amule/amule-2.2.6.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.14 2012/02/16 17:17:32 jer Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic wxwidgets
-
-MY_P=${PN/m/M}-${PV}
-S="${WORKDIR}"/${MY_P}
-
-DESCRIPTION="aMule, the all-platform eMule p2p client"
-HOMEPAGE="http://www.amule.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 ~sparc x86"
-IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
-
-DEPEND="=x11-libs/wxGTK-2.8*
- >=dev-libs/crypto++-5
- >=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.26[jpeg] )
- geoip? ( dev-libs/geoip )
- upnp? ( >=net-libs/libupnp-1.6.6 )
- remote? ( >=media-libs/libpng-1.2.0
- unicode? ( >=media-libs/gd-2.0.26 ) )"
-
-pkg_setup() {
- if ! use gtk && ! use remote && ! use daemon; then
- eerror ""
- eerror "You have to specify at least one of gtk, remote or daemon"
- eerror "USE flag to build amule."
- eerror ""
- die "Invalid USE flag set"
- fi
-
- if use stats && ! use gtk; then
- einfo "Note: You would need both the gtk and stats USE flags"
- einfo "to compile aMule Statistics GUI."
- einfo "I will now compile console versions only."
- fi
-}
-
-pkg_preinst() {
- if use daemon || use remote; then
- enewgroup p2p
- enewuser p2p -1 -1 /home/p2p p2p
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fallocate.diff
- epatch "${FILESDIR}"/${P}-gcc45.patch
-}
-
-src_configure() {
- local myconf
-
- WX_GTK_VER="2.8"
-
- if use gtk; then
- einfo "wxGTK with gtk support will be used"
- need-wxwidgets unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base
- fi
-
- if use gtk ; then
- use stats && myconf="${myconf}
- --enable-wxcas
- --enable-alc"
- use remote && myconf="${myconf}
- --enable-amule-gui"
- else
- myconf="
- --disable-monolithic
- --disable-amule-gui
- --disable-wxcas
- --disable-alc"
- fi
-
- econf \
- --with-wx-config=${WX_CONFIG} \
- --with-wxbase-config=${WX_CONFIG} \
- --enable-amulecmd \
- $(use_enable debug) \
- $(use_enable !debug optimize) \
- $(use_enable daemon amule-daemon) \
- $(use_enable geoip) \
- $(use_enable nls) \
- $(use_enable remote webserver) \
- $(use_enable stats cas) \
- $(use_enable stats alcc) \
- ${myconf} || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use daemon; then
- newconfd "${FILESDIR}"/amuled.confd amuled
- newinitd "${FILESDIR}"/amuled.initd amuled
- fi
- if use remote; then
- newconfd "${FILESDIR}"/amuleweb.confd amuleweb
- newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- fi
-}
diff --git a/net-p2p/amule/amule-2.3.1.ebuild b/net-p2p/amule/amule-2.3.1.ebuild
index f2a6daa2e2d2..b37a0289cbe9 100644
--- a/net-p2p/amule/amule-2.3.1.ebuild
+++ b/net-p2p/amule/amule-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.3.1.ebuild,v 1.8 2012/05/21 12:25:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.3.1.ebuild,v 1.9 2012/06/03 16:57:23 armin76 Exp $
EAPI="2"
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ppc ppc64 ~sparc x86"
+KEYWORDS="alpha amd64 ppc ppc64 ~sparc x86"
IUSE="daemon debug geoip nls remote stats unicode upnp +X"
DEPEND=">=dev-libs/crypto++-5
diff --git a/net-p2p/amule/files/amule-2.2.6-gcc45.patch b/net-p2p/amule/files/amule-2.2.6-gcc45.patch
deleted file mode 100644
index e120ef23b76f..000000000000
--- a/net-p2p/amule/files/amule-2.2.6-gcc45.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-# Subject: Fix FTBFS on gcc 4.5 (new in ubuntu natty)
-# Origin: other, http://bugs.amule.org/view.php?id=1624
-# Bug-ubuntu: https://bugs.launchpad.net/ubuntu/+source/amule/+bug/685584
-# Forwarded: upstream claims it's in their current svn code
-Index: amule-2.2.6+debian0/src/utils/wxCas/src/wxcasframe.cpp
-===================================================================
---- amule-2.2.6+debian0.orig/src/utils/wxCas/src/wxcasframe.cpp 2010-12-15 16:46:18.435693002 +0000
-+++ amule-2.2.6+debian0/src/utils/wxCas/src/wxcasframe.cpp 2010-12-15 16:47:07.151693001 +0000
-@@ -285,11 +285,11 @@
- #ifdef __WXMSW__
-
- memdc.
-- SetFont ( wxFont::wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
-+ SetFont ( wxFont ( 6, wxSWISS, wxNORMAL, wxBOLD ) );
- #else
-
- memdc.
-- SetFont ( wxFont::wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
-+ SetFont ( wxFont ( 8, wxSWISS, wxNORMAL, wxBOLD ) );
- #endif
-
- memdc.