summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-11-27 20:45:24 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-11-27 20:45:24 +0000
commit0c9d9ec35c94f724e0fd9c7ba95feba65150458b (patch)
tree0fb2d9fd7b01b4d7c22428ec769a5b51c7add525 /net-p2p/amule
parentBump to 0.98 (diff)
downloadgentoo-2-0c9d9ec35c94f724e0fd9c7ba95feba65150458b.tar.gz
gentoo-2-0c9d9ec35c94f724e0fd9c7ba95feba65150458b.tar.bz2
gentoo-2-0c9d9ec35c94f724e0fd9c7ba95feba65150458b.zip
Remove make_desktop_entry as its not needed, bug #241676, and fix upnp dependency, bug 247126
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog7
-rw-r--r--net-p2p/amule/amule-2.2.1.ebuild115
-rw-r--r--net-p2p/amule/amule-2.2.2.ebuild5
3 files changed, 8 insertions, 119 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index b9cfaab8c439..e9fe4f0788d9 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.120 2008/08/08 19:55:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.121 2008/11/27 20:45:24 armin76 Exp $
+
+ 27 Nov 2008; Raúl Porcel <armin76@gentoo.org> -amule-2.2.1.ebuild,
+ amule-2.2.2.ebuild:
+ Remove make_desktop_entry as its not needed, bug #241676, and fix upnp
+ dependency, bug 247126
*amule-2.2.2 (08 Aug 2008)
diff --git a/net-p2p/amule/amule-2.2.1.ebuild b/net-p2p/amule/amule-2.2.1.ebuild
deleted file mode 100644
index e94893c61b93..000000000000
--- a/net-p2p/amule/amule-2.2.1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.1.ebuild,v 1.1 2008/06/13 10:21:53 armin76 Exp $
-
-inherit eutils flag-o-matic wxwidgets
-
-MY_P=${PN/m/M}-${PV}
-S="${WORKDIR}"/${MY_P}
-
-DESCRIPTION="aMule, the all-platform eMule p2p client"
-HOMEPAGE="http://www.amule.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
-
-DEPEND="=x11-libs/wxGTK-2.8*
- >=dev-libs/crypto++-5.5.2
- >=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.26 )
- geoip? ( dev-libs/geoip )
- upnp? ( net-libs/libupnp )
- remote? ( >=media-libs/libpng-1.2.0
- unicode? ( >=media-libs/gd-2.0.26 ) )"
-
-pkg_setup() {
- if ! use gtk && ! use remote && ! use daemon; then
- eerror ""
- eerror "You have to specify at least one of gtk, remote or daemon"
- eerror "USE flag to build amule."
- eerror ""
- die "Invalid USE flag set"
- fi
-
- if use stats && ! use gtk; then
- einfo "Note: You would need both the gtk and stats USE flags"
- einfo "to compile aMule Statistics GUI."
- einfo "I will now compile console versions only."
- fi
-
- if use stats && ! built_with_use media-libs/gd jpeg; then
- die "media-libs/gd should be compiled with the jpeg use flag when you have the stats use flag set"
- fi
-}
-
-pkg_preinst() {
- if use daemon || use remote; then
- enewgroup p2p
- enewuser p2p -1 -1 /home/p2p p2p
- fi
-}
-
-src_compile() {
- local myconf
-
- WX_GTK_VER="2.8"
-
- if use gtk; then
- einfo "wxGTK with gtk support will be used"
- need-wxwidgets unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base
- fi
-
- if use gtk ; then
- use stats && myconf="${myconf}
- --enable-wxcas
- --enable-alc"
- use remote && myconf="${myconf}
- --enable-amule-gui"
- else
- myconf="
- --disable-monolithic
- --disable-amule-gui
- --disable-wxcas
- --disable-alc"
- fi
-
- econf \
- --with-wx-config=${WX_CONFIG} \
- --with-wxbase-config=${WX_CONFIG} \
- --enable-amulecmd \
- $(use_enable debug) \
- $(use_enable !debug optimize) \
- $(use_enable daemon amule-daemon) \
- $(use_enable geoip) \
- $(use_enable nls) \
- $(use_enable remote webserver) \
- $(use_enable stats cas) \
- $(use_enable stats alcc) \
- ${myconf} || die
-
- # we filter ssp until bug #74457 is closed to build on hardened
- filter-flags -fstack-protector -fstack-protector-all
-
- emake -j1 || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use daemon; then
- newconfd "${FILESDIR}"/amuled.confd amuled
- newinitd "${FILESDIR}"/amuled.initd amuled
- fi
-
- if use remote; then
- newconfd "${FILESDIR}"/amuleweb.confd amuleweb
- newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- make_desktop_entry amulegui "aMule Remote" amule "Network;P2P"
- fi
-}
diff --git a/net-p2p/amule/amule-2.2.2.ebuild b/net-p2p/amule/amule-2.2.2.ebuild
index 449619ee7ea8..578014849587 100644
--- a/net-p2p/amule/amule-2.2.2.ebuild
+++ b/net-p2p/amule/amule-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.2.ebuild,v 1.1 2008/08/08 19:55:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.2.ebuild,v 1.2 2008/11/27 20:45:24 armin76 Exp $
inherit eutils flag-o-matic wxwidgets
@@ -21,7 +21,7 @@ DEPEND="=x11-libs/wxGTK-2.8*
>=sys-libs/zlib-1.2.1
stats? ( >=media-libs/gd-2.0.26 )
geoip? ( dev-libs/geoip )
- upnp? ( net-libs/libupnp )
+ upnp? ( >=net-libs/libupnp-1.6.6 )
remote? ( >=media-libs/libpng-1.2.0
unicode? ( >=media-libs/gd-2.0.26 ) )"
@@ -110,6 +110,5 @@ src_install() {
if use remote; then
newconfd "${FILESDIR}"/amuleweb.confd amuleweb
newinitd "${FILESDIR}"/amuleweb.initd amuleweb
- make_desktop_entry amulegui "aMule Remote" amule "Network;P2P"
fi
}