summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-16 16:43:50 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-16 16:43:50 +0000
commit3b8d6c1e979c36ee1def6c3b0bc383124d206bb7 (patch)
tree4858e2b687a7937613ad7a8e8789ae918094e99a /net-nntp
parentAdded cross-compile support. (diff)
downloadgentoo-2-3b8d6c1e979c36ee1def6c3b0bc383124d206bb7.tar.gz
gentoo-2-3b8d6c1e979c36ee1def6c3b0bc383124d206bb7.tar.bz2
gentoo-2-3b8d6c1e979c36ee1def6c3b0bc383124d206bb7.zip
Added error checking to src_install.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/ubh/ChangeLog5
-rw-r--r--net-nntp/ubh/ubh-2.5.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/net-nntp/ubh/ChangeLog b/net-nntp/ubh/ChangeLog
index 7ba9cbd37db8..b5318d177f54 100644
--- a/net-nntp/ubh/ChangeLog
+++ b/net-nntp/ubh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-nntp/ubh
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/ubh/ChangeLog,v 1.2 2005/01/17 21:55:23 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/ubh/ChangeLog,v 1.3 2005/05/16 16:43:50 swegener Exp $
+
+ 16 May 2005; Sven Wegener <swegener@gentoo.org> ubh-2.5.ebuild:
+ Added error checking to src_install.
*ubh-2.5 (17 Jan 2005)
diff --git a/net-nntp/ubh/ubh-2.5.ebuild b/net-nntp/ubh/ubh-2.5.ebuild
index 17618afe4680..a63db4ceddac 100644
--- a/net-nntp/ubh/ubh-2.5.ebuild
+++ b/net-nntp/ubh/ubh-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/ubh/ubh-2.5.ebuild,v 1.1 2005/01/17 20:24:19 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/ubh/ubh-2.5.ebuild,v 1.2 2005/05/16 16:43:50 swegener Exp $
DESCRIPTION="The Usenet Binary Harvester"
HOMEPAGE="http://ubh.sourceforge.net/"
@@ -10,16 +10,16 @@ SLOT="0"
IUSE=""
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
DEPEND=">=dev-perl/libnet-1.0607
- >=dev-perl/News-Newsrc-1.07
- >=dev-perl/IO-stringy-1.220
- >=dev-perl/MIME-Base64-2.12
- >=dev-perl/MailTools-1.15
- >=dev-perl/MIME-tools-5.411
- >=dev-perl/string-crc32-1.2"
+ >=dev-perl/News-Newsrc-1.07
+ >=dev-perl/IO-stringy-1.220
+ >=dev-perl/MIME-Base64-2.12
+ >=dev-perl/MailTools-1.15
+ >=dev-perl/MIME-tools-5.411
+ >=dev-perl/string-crc32-1.2"
src_install() {
- dobin ${S}/ubh
- dohtml ${S}/doc/ubh.html
+ dobin ubh || die "dobin failed"
+ dohtml doc/ubh.html || die "dohtml failed"
insinto /usr/share/${P}
- doins ${S}/examples/newsrc ${S}/examples/ubhrc
+ doins examples/{newsrc,ubhrc} || die "doins failed"
}