summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-15 11:12:28 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-15 11:12:28 +0000
commitc0a29e34f4e33824071083b244e6eda0f638c5b7 (patch)
treec20c52ae5fa76759b6f50b6323bc85ea2ba90915 /net-nds/openldap
parentFix dependencies. Cleanup (diff)
downloadgentoo-2-c0a29e34f4e33824071083b244e6eda0f638c5b7.tar.gz
gentoo-2-c0a29e34f4e33824071083b244e6eda0f638c5b7.tar.bz2
gentoo-2-c0a29e34f4e33824071083b244e6eda0f638c5b7.zip
Fix ebuilds with EAPI=2, bug #255021
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/ChangeLog6
-rw-r--r--net-nds/openldap/openldap-2.3.43-r1.ebuild10
-rw-r--r--net-nds/openldap/openldap-2.3.43.ebuild10
-rw-r--r--net-nds/openldap/openldap-2.4.11-r1.ebuild11
4 files changed, 20 insertions, 17 deletions
diff --git a/net-nds/openldap/ChangeLog b/net-nds/openldap/ChangeLog
index c8dce4cf950b..4108a611c95a 100644
--- a/net-nds/openldap/ChangeLog
+++ b/net-nds/openldap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/openldap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.338 2009/01/13 20:20:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.339 2009/01/15 11:12:28 armin76 Exp $
+
+ 15 Jan 2009; Raúl Porcel <armin76@gentoo.org> openldap-2.3.43.ebuild,
+ openldap-2.3.43-r1.ebuild, openldap-2.4.11-r1.ebuild:
+ Fix ebuilds with EAPI=2, bug #255021
13 Jan 2009; Raúl Porcel <armin76@gentoo.org> openldap-2.3.43.ebuild,
openldap-2.3.43-r1.ebuild, openldap-2.4.11-r1.ebuild:
diff --git a/net-nds/openldap/openldap-2.3.43-r1.ebuild b/net-nds/openldap/openldap-2.3.43-r1.ebuild
index decb03a6b3a9..ff64629bb812 100644
--- a/net-nds/openldap/openldap-2.3.43-r1.ebuild
+++ b/net-nds/openldap/openldap-2.3.43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.3.43-r1.ebuild,v 1.3 2009/01/13 20:20:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.3.43-r1.ebuild,v 1.4 2009/01/15 11:12:28 armin76 Exp $
EAPI="2"
@@ -187,9 +187,7 @@ pkg_setup() {
enewuser ldap 439 -1 /usr/$(get_libdir)/openldap ldap
}
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# According to MDK, the link order needs to be changed so that
# on systems w/ MD5 passwords the system crypt library is used
# (the net result is that "passwd" can be used to change ldap passwords w/
@@ -233,7 +231,7 @@ src_unpack() {
fi
}
-src_compile() {
+src_configure() {
local myconf
#Fix for glibc-2.8 and ucred. Bug 228457.
@@ -309,7 +307,9 @@ src_compile() {
--enable-shared \
--libexecdir=/usr/$(get_libdir)/openldap \
${myconf} || die "configure failed"
+}
+src_compile() {
emake depend || die "make depend failed"
emake || die "make failed"
diff --git a/net-nds/openldap/openldap-2.3.43.ebuild b/net-nds/openldap/openldap-2.3.43.ebuild
index 796c1c1fe3fe..5259dd88367a 100644
--- a/net-nds/openldap/openldap-2.3.43.ebuild
+++ b/net-nds/openldap/openldap-2.3.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.3.43.ebuild,v 1.9 2009/01/13 20:20:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.3.43.ebuild,v 1.10 2009/01/15 11:12:28 armin76 Exp $
EAPI="2"
@@ -187,9 +187,7 @@ pkg_setup() {
enewuser ldap 439 -1 /usr/$(get_libdir)/openldap ldap
}
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# According to MDK, the link order needs to be changed so that
# on systems w/ MD5 passwords the system crypt library is used
# (the net result is that "passwd" can be used to change ldap passwords w/
@@ -232,7 +230,7 @@ src_unpack() {
fi
}
-src_compile() {
+src_configure() {
local myconf
#Fix for glibc-2.8 and ucred. Bug 228457.
@@ -308,7 +306,9 @@ src_compile() {
--enable-shared \
--libexecdir=/usr/$(get_libdir)/openldap \
${myconf} || die "configure failed"
+}
+src_compile() {
emake depend || die "make depend failed"
emake || die "make failed"
diff --git a/net-nds/openldap/openldap-2.4.11-r1.ebuild b/net-nds/openldap/openldap-2.4.11-r1.ebuild
index 4084793f95c8..f484e3cf4457 100644
--- a/net-nds/openldap/openldap-2.4.11-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.11-r1.ebuild,v 1.4 2009/01/13 20:20:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.11-r1.ebuild,v 1.5 2009/01/15 11:12:28 armin76 Exp $
EAPI="2"
inherit db-use eutils flag-o-matic multilib ssl-cert versionator toolchain-funcs
@@ -165,10 +165,7 @@ pkg_setup() {
enewuser ldap 439 -1 /usr/$(get_libdir)/openldap ldap
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# ensure correct SLAPI path by default
sed -i -e 's,\(#define LDAPI_SOCK\).*,\1 "/var/run/openldap/slapd.sock",' \
"${S}"/include/ldap_defaults.h
@@ -200,7 +197,7 @@ build_contrib_module() {
${LDFLAGS} -o $3.so $2 || die "building $3 failed"
}
-src_compile() {
+src_configure() {
local myconf
#Fix for glibc-2.8 and ucred. Bug 228457.
@@ -276,7 +273,9 @@ src_compile() {
econf \
--libexecdir=/usr/$(get_libdir)/openldap \
${myconf} || die "configure failed"
+}
+src_compile() {
emake depend || die "emake depend failed"
emake CC=$(tc-getCC) AR=$(tc-getAR) || die "emake failed"