summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-12 08:46:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-12 08:46:12 +0000
commite7fae1ceafe01ae497f28fa28ca48f4c16b4adac (patch)
tree47fce3fe1cf51113f5ff7140b828e92b3ec3fcbc /net-misc
parentVersion bump. (diff)
downloadgentoo-2-e7fae1ceafe01ae497f28fa28ca48f4c16b4adac.tar.gz
gentoo-2-e7fae1ceafe01ae497f28fa28ca48f4c16b4adac.tar.bz2
gentoo-2-e7fae1ceafe01ae497f28fa28ca48f4c16b4adac.zip
Bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-4.7.36.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 3bbc9699c77b..208d4e225e48 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.128 2009/06/25 22:28:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.129 2009/09/12 08:46:12 patrick Exp $
+
+*whois-4.7.36 (12 Sep 2009)
+
+ 12 Sep 2009; Patrick Lauer <patrick@gentoo.org> +whois-4.7.36.ebuild:
+ Bump
*whois-4.7.34 (25 Jun 2009)
diff --git a/net-misc/whois/whois-4.7.36.ebuild b/net-misc/whois/whois-4.7.36.ebuild
new file mode 100644
index 000000000000..06b3443a8b29
--- /dev/null
+++ b/net-misc/whois/whois-4.7.36.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.7.36.ebuild,v 1.1 2009/09/12 08:46:12 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.26-gentoo-security.patch
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ emake BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${D}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${D}"/usr/bin/{whois,mdwhois}
+ fi
+}