summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-01 06:39:07 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-01 06:39:07 +0000
commita7f2ad5487f05462887318ea4adf393316c59624 (patch)
tree2f75ae683a648920d479ec96d7047841b90aa622 /net-misc
parentmarked x86 per bug 429212 (diff)
downloadgentoo-2-a7f2ad5487f05462887318ea4adf393316c59624.tar.gz
gentoo-2-a7f2ad5487f05462887318ea4adf393316c59624.tar.bz2
gentoo-2-a7f2ad5487f05462887318ea4adf393316c59624.zip
Add after ntpd (bug 390611, thanks Ewoud Kohl van Wijngaarden), fix setupscript functionality (bug 353803, thanks Mateusz Dziadko), assign RDEPEND
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/aiccu/ChangeLog10
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r1.ebuild7
-rw-r--r--net-misc/aiccu/aiccu-2007.01.15-r2.ebuild45
-rw-r--r--net-misc/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch33
-rw-r--r--net-misc/aiccu/files/aiccu-2007.01.15-setupscript.patch17
5 files changed, 109 insertions, 3 deletions
diff --git a/net-misc/aiccu/ChangeLog b/net-misc/aiccu/ChangeLog
index cd14b5386be6..b1bec3cef8cc 100644
--- a/net-misc/aiccu/ChangeLog
+++ b/net-misc/aiccu/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/aiccu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.31 2012/08/01 04:56:13 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/ChangeLog,v 1.32 2012/08/01 06:39:07 xmw Exp $
+
+*aiccu-2007.01.15-r2 (01 Aug 2012)
+
+ 01 Aug 2012; Michael Weber <xmw@gentoo.org> +aiccu-2007.01.15-r2.ebuild,
+ +files/aiccu-2007.01.15-r2-init.gentoo.patch,
+ +files/aiccu-2007.01.15-setupscript.patch, aiccu-2007.01.15-r1.ebuild:
+ Add after ntpd (bug 390611, thanks Ewoud Kohl van Wijngaarden), fix
+ setupscript functionality (bug 353803, thanks Mateusz Dziadko), assign RDEPEND
01 Aug 2012; Michael Weber <xmw@gentoo.org> metadata.xml:
Add myself as maintainer.
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild
index 821b90679b1c..61ca1f27b938 100644
--- a/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild
+++ b/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild,v 1.6 2011/06/24 18:58:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r1.ebuild,v 1.7 2012/08/01 06:39:07 xmw Exp $
EAPI=3
@@ -14,8 +14,11 @@ LICENSE="SixXS"
SLOT="0"
KEYWORDS="amd64 arm hppa ppc sparc x86"
IUSE=""
+
DEPEND="net-libs/gnutls
sys-apps/iproute2"
+RDEPEND="${DEPEND}"
+
S=${WORKDIR}/aiccu
src_prepare() {
diff --git a/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild b/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild
new file mode 100644
index 000000000000..3203ddd82e98
--- /dev/null
+++ b/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2007.01.15-r2.ebuild,v 1.1 2012/08/01 06:39:07 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
+HOMEPAGE="http://www.sixxs.net/tools/aiccu"
+SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
+
+LICENSE="SixXS"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls
+ sys-apps/iproute2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/aiccu
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-init.gentoo.patch
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-setupscript.patch
+}
+
+src_compile() {
+ # Don't use main Makefile since it requires additional
+ # dependencies which are useless for us.
+ emake CC=$(tc-getCC) STRIP= -C unix-console
+}
+
+src_install() {
+ dosbin unix-console/${PN}
+
+ insopts -m 600
+ insinto /etc
+ doins doc/${PN}.conf
+ newinitd doc/${PN}.init.gentoo ${PN}
+
+ dodoc doc/{HOWTO,README,changelog}
+}
diff --git a/net-misc/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch b/net-misc/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch
new file mode 100644
index 000000000000..35ca2b8a6719
--- /dev/null
+++ b/net-misc/aiccu/files/aiccu-2007.01.15-r2-init.gentoo.patch
@@ -0,0 +1,33 @@
+--- aiccu/doc/aiccu.init.gentoo
++++ aiccu/doc/aiccu.init.gentoo
+@@ -2,7 +2,7 @@
+
+ depend() {
+ need net
+- after ntp-client
++ after ntp-client ntpd
+ }
+
+ checkconfig() {
+@@ -23,14 +23,19 @@
+ start() {
+ checkconfig || return 1
+ ebegin "Starting aiccu"
+- start-stop-daemon --start --oknodo --quiet --exec /usr/sbin/aiccu -- start
++ start-stop-daemon --start --quiet --exec /usr/sbin/aiccu -- start
+ eend $?
+ }
+
+
+ stop() {
+ ebegin "Stopping aiccu"
+- start-stop-daemon --stop --oknodo --quiet --exec /usr/sbin/aiccu -- stop
++ start-stop-daemon --stop --pidfile /var/run/aiccu.pid --quiet --exec /usr/sbin/aiccu -- stop
+ eend $?
+ }
+
++restart() {
++ stop
++ sleep 3
++ start
++}
diff --git a/net-misc/aiccu/files/aiccu-2007.01.15-setupscript.patch b/net-misc/aiccu/files/aiccu-2007.01.15-setupscript.patch
new file mode 100644
index 000000000000..8981530435f3
--- /dev/null
+++ b/net-misc/aiccu/files/aiccu-2007.01.15-setupscript.patch
@@ -0,0 +1,17 @@
+--- aiccu/unix-console/main.c
++++ aiccu/unix-console/main.c
+@@ -471,6 +471,14 @@
+ */
+ if (aiccu_setup(hTunnel, true))
+ {
++
++ /* Running setup script */
++ if (g_aiccu->setupscript)
++ {
++ aiccu_exec("%s", g_aiccu->setupscript);
++ }
++
++
+ /* We need to stay running when doing Heartbeat or AYIYA */
+ if ( strcasecmp(hTunnel->sType, "6in4-heartbeat") == 0 ||
+ strcasecmp(hTunnel->sType, "ayiya") == 0)