summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-02-28 23:10:40 +0000
committerChris Reffett <creffett@gentoo.org>2013-02-28 23:10:40 +0000
commit827d68d3143520c2bec679153e31a6984247392b (patch)
tree3f0ef51fdac2d4bcb28233e0a87f2fddb36bd3e9 /net-misc
parentAdd bind-9.8.4_p1, bug 459518. Update named.cache, bug 456396. Fix named.cach... (diff)
downloadgentoo-2-827d68d3143520c2bec679153e31a6984247392b.tar.gz
gentoo-2-827d68d3143520c2bec679153e31a6984247392b.tar.bz2
gentoo-2-827d68d3143520c2bec679153e31a6984247392b.zip
Version bump wrt bug 459476
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/csync/ChangeLog7
-rw-r--r--net-misc/csync/csync-0.70.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/csync/ChangeLog b/net-misc/csync/ChangeLog
index 593460e67fda..b07aba79f7ad 100644
--- a/net-misc/csync/ChangeLog
+++ b/net-misc/csync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/csync
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/ChangeLog,v 1.12 2013/01/31 15:25:18 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/ChangeLog,v 1.13 2013/02/28 23:10:40 creffett Exp $
+
+*csync-0.70.4 (28 Feb 2013)
+
+ 28 Feb 2013; Chris Reffett <creffett@gentoo.org> +csync-0.70.4.ebuild:
+ Version bump wrt bug 459476
*csync-0.70.3 (31 Jan 2013)
diff --git a/net-misc/csync/csync-0.70.4.ebuild b/net-misc/csync/csync-0.70.4.ebuild
new file mode 100644
index 000000000000..3d151fe1b9ca
--- /dev/null
+++ b/net-misc/csync/csync-0.70.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/csync-0.70.4.ebuild,v 1.1 2013/02/28 23:10:40 creffett Exp $
+
+EAPI=5
+
+inherit base cmake-utils
+
+DESCRIPTION="A file synchronizer especially designed for you, the normal user"
+HOMEPAGE="http://csync.org/"
+SRC_URI="http://download.owncloud.com/download/o${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv log samba +sftp test +webdav"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/iniparser-3.1
+ dev-libs/openssl:0
+ iconv? ( virtual/libiconv )
+ log? ( dev-libs/log4c )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh )
+ webdav? ( net-libs/neon )
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check dev-util/cmocka )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.70.1-automagicness.patch"
+ "${FILESDIR}/${PN}-0.60.2-removebadtest.patch"
+)
+
+S="${WORKDIR}/o${P}"
+
+src_prepare() {
+ base_src_prepare
+
+ if ! use doc; then
+ sed -i \
+ -e 's:add_subdirectory(doc)::' \
+ CMakeLists.txt || die
+ fi
+
+ # proper docdir
+ sed -i \
+ -e "s:/doc/ocsync:/doc/${PF}:" \
+ doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOG_TO_CALLBACK=ON"
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_with doc APIDOC)
+ $(cmake-utils_use_with log Log4C)
+ $(cmake-utils_use_with samba Libsmbclient)
+ $(cmake-utils_use_with sftp LibSSH)
+ $(cmake-utils_use_with webdav Neon)
+ )
+ cmake-utils_src_configure
+}