summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-10-13 21:37:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-10-13 21:37:43 +0000
commit6c399f82d28f696ac5a031b9f4adadf79e4c131d (patch)
tree4a45521f2c62e16acff00a21998398393cc4db32 /net-misc
parentDon't RDEPEND on xml documentation tools. (diff)
downloadgentoo-2-6c399f82d28f696ac5a031b9f4adadf79e4c131d.tar.gz
gentoo-2-6c399f82d28f696ac5a031b9f4adadf79e4c131d.tar.bz2
gentoo-2-6c399f82d28f696ac5a031b9f4adadf79e4c131d.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.28.0.ebuild204
-rw-r--r--net-misc/curl/files/curl-7.28.0-prefix.patch21
-rw-r--r--net-misc/curl/metadata.xml1
4 files changed, 233 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 553aad4cd1ef..82ddbd213e0e 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.249 2012/09/06 10:28:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.250 2012/10/13 21:37:43 blueness Exp $
+
+*curl-7.28.0 (13 Oct 2012)
+
+ 13 Oct 2012; Anthony G. Basile <blueness@gentoo.org> +curl-7.28.0.ebuild,
+ +files/curl-7.28.0-prefix.patch, curl-7.27.0-r3.ebuild, metadata.xml:
+ Version bump
06 Sep 2012; Anthony G. Basile <blueness@gentoo.org> curl-7.26.0.ebuild:
Stable ppc64, bug #421479
diff --git a/net-misc/curl/curl-7.28.0.ebuild b/net-misc/curl/curl-7.28.0.ebuild
new file mode 100644
index 000000000000..d9b1552c0a39
--- /dev/null
+++ b/net-misc/curl/curl-7.28.0.ebuild
@@ -0,0 +1,204 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.28.0.ebuild,v 1.1 2012/10/13 21:37:43 blueness Exp $
+
+EAPI="4"
+
+inherit autotools eutils prefix
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="adns idn ipv6 kerberos ldap metalink +nonblocking rtmp ssh ssl static-libs test threads"
+IUSE="${IUSE} curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl curl_ssl_polarssl"
+
+#lead to lots of false negatives, bug #285669
+RESTRICT="test"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ ssl? (
+ curl_ssl_axtls? ( net-libs/axtls app-misc/ca-certificates )
+ curl_ssl_cyassl? ( net-libs/cyassl app-misc/ca-certificates )
+ curl_ssl_gnutls? (
+ || (
+ ( >=net-libs/gnutls-3[static-libs?] dev-libs/nettle )
+ ( =net-libs/gnutls-2.12*[nettle,static-libs?] dev-libs/nettle )
+ ( =net-libs/gnutls-2.12*[-nettle,static-libs?] dev-libs/libgcrypt[static-libs?] )
+ )
+ app-misc/ca-certificates
+ )
+ curl_ssl_openssl? ( dev-libs/openssl[static-libs?] )
+ curl_ssl_nss? ( dev-libs/nss app-misc/ca-certificates )
+ curl_ssl_polarssl? ( net-libs/polarssl app-misc/ca-certificates )
+ )
+ idn? ( net-dns/libidn[static-libs?] )
+ adns? ( net-dns/c-ares )
+ kerberos? ( virtual/krb5 )
+ metalink? ( >=media-libs/libmetalink-0.1.0 )
+ rtmp? ( media-video/rtmpdump )
+ ssh? ( net-libs/libssh2[static-libs?] )
+ sys-libs/zlib"
+
+# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
+# rtmp? (
+# media-video/rtmpdump
+# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
+# curl_ssl_polarssl? ( media-video/rtmpdump[polarssl] )
+# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,-polarssl,ssl] )
+# )
+
+# ssl providers to be added:
+# fbopenssl $(use_with spnego)
+
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ sys-apps/ed
+ virtual/pkgconfig
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+
+# c-ares must be disabled for threads
+# only one ssl provider can be enabled
+REQUIRED_USE="
+ threads? ( !adns )
+ ssl? (
+ ^^ (
+ curl_ssl_axtls
+ curl_ssl_cyassl
+ curl_ssl_gnutls
+ curl_ssl_openssl
+ curl_ssl_nss
+ curl_ssl_polarssl
+ )
+ )"
+
+DOCS=( CHANGES README docs/FEATURES docs/INTERNALS \
+ docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7.28.0-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch \
+ "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
+ sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
+
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+src_configure() {
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # We make use of the fact that later flags override earlier ones
+ # So start with all ssl providers off until proven otherwise
+ local myconf=()
+ myconf+=( --without-axtls --without-cyassl --without-gnutls --without-nss --without-polarssl --without-ssl )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ if use ssl ; then
+ if use curl_ssl_axtls; then
+ einfo "SSL provided by axtls"
+ einfo "NOTE: axtls is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-axtls )
+ fi
+ if use curl_ssl_cyassl; then
+ einfo "SSL provided by cyassl"
+ einfo "NOTE: cyassl is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-cyassl )
+ fi
+ if use curl_ssl_gnutls; then
+ einfo "SSL provided by gnutls"
+ if has_version ">=net-libs/gnutls-3" || has_version "=net-libs/gnutls-2.12*[nettle]"; then
+ einfo "gnutls compiled with dev-libs/nettle"
+ myconf+=( --with-gnutls --with-nettle )
+ else
+ einfo "gnutls compiled with dev-libs/libgcrypt"
+ myconf+=( --with-gnutls --without-nettle )
+ fi
+ fi
+ if use curl_ssl_nss; then
+ einfo "SSL provided by nss"
+ myconf+=( --with-nss )
+ fi
+ if use curl_ssl_polarssl; then
+ einfo "SSL provided by polarssl"
+ einfo "NOTE: polarssl is meant for embedded systems and"
+ einfo "may not be the best choice as an ssl provider"
+ myconf+=( --with-polarssl )
+ fi
+ if use curl_ssl_openssl; then
+ einfo "SSL provided by openssl"
+ myconf+=( --with-ssl --without-ca-bundle --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ fi
+ else
+ einfo "SSL disabled"
+ fi
+ einfo "\033[1;32m**************************************************\033[00m"
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we
+ # ever decide to make any of them contingent on USE flags:
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+ econf \
+ --enable-dict \
+ --enable-file \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-http \
+ --enable-imap \
+ $(use_enable ldap) \
+ $(use_enable ldap ldaps) \
+ --enable-pop3 \
+ --enable-rtsp \
+ $(use_with ssh libssh2) \
+ --enable-smtp \
+ --enable-telnet \
+ --enable-tftp \
+ $(use_enable adns ares) \
+ --enable-cookies \
+ --enable-hidden-symbols \
+ $(use_enable ipv6) \
+ --enable-largefile \
+ --enable-manual \
+ $(use_enable nonblocking) \
+ --enable-proxy \
+ --disable-soname-bump \
+ --disable-sspi \
+ $(use_enable static-libs static) \
+ $(use_enable threads threaded-resolver) \
+ --disable-versioned-symbols \
+ --without-darwinssl \
+ $(use_with idn libidn) \
+ $(use_with kerberos gssapi "${EPREFIX}"/usr) \
+ --without-krb4 \
+ $(use_with metalink libmetalink) \
+ $(use_with rtmp librtmp) \
+ --without-spnego \
+ --without-winidn \
+ --without-winssl \
+ --with-zlib \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+}
diff --git a/net-misc/curl/files/curl-7.28.0-prefix.patch b/net-misc/curl/files/curl-7.28.0-prefix.patch
new file mode 100644
index 000000000000..377d03b06121
--- /dev/null
+++ b/net-misc/curl/files/curl-7.28.0-prefix.patch
@@ -0,0 +1,21 @@
+diff -Nuar curl-7.28.0.orig/curl-config.in curl-7.28.0/curl-config.in
+--- curl-7.28.0.orig/curl-config.in 2012-08-08 17:38:25.000000000 -0400
++++ curl-7.28.0/curl-config.in 2012-10-13 17:11:30.000000000 -0400
+@@ -134,7 +134,7 @@
+ else
+ CPPFLAG_CURL_STATICLIB=""
+ fi
+- if test "X@includedir@" = "X/usr/include"; then
++ if test "X@includedir@" = "X@GENTOO_PORTAGE_EPREFIX@/usr/include"; then
+ echo "$CPPFLAG_CURL_STATICLIB"
+ else
+ echo "${CPPFLAG_CURL_STATICLIB}-I@includedir@"
+@@ -142,7 +142,7 @@
+ ;;
+
+ --libs)
+- if test "X@libdir@" != "X/usr/lib" -a "X@libdir@" != "X/usr/lib64"; then
++ if test "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib" -a "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib64"; then
+ CURLLIBDIR="-L@libdir@ "
+ else
+ CURLLIBDIR=""
diff --git a/net-misc/curl/metadata.xml b/net-misc/curl/metadata.xml
index 8cdbd910ded9..b84246390036 100644
--- a/net-misc/curl/metadata.xml
+++ b/net-misc/curl/metadata.xml
@@ -14,6 +14,7 @@
<flag name="ssh">Enabled SSH urls in curl using libssh2</flag>
<flag name="gnutls">Prefer gnutls over nss and openssl as the crypto engine</flag>
<flag name="metalink">Enalbe metalink support</flag>
+ <flag name="nonblocking">Enalbe nonblocking communication</flag>
<flag name="nss">Prefer NSS over openssl as the crypto engine</flag>
<flag name="ssl">Enable crypto engine support (via openssl if USE='-gnutls -nss')</flag>
<flag name="rtmp">Enable Enables RTMPDump Streaming Media support</flag>