summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-05-03 20:05:14 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-05-03 20:05:14 +0000
commit5c9a4a0d239a9a56fa914408139c6673888c8b1c (patch)
tree62977913acaec96ab9178afa1d66b151c57a0bde /net-misc
parentImport patch from Debian http://bugs.debian.org/347650 which hacks around lib... (diff)
downloadgentoo-2-5c9a4a0d239a9a56fa914408139c6673888c8b1c.tar.gz
gentoo-2-5c9a4a0d239a9a56fa914408139c6673888c8b1c.tar.bz2
gentoo-2-5c9a4a0d239a9a56fa914408139c6673888c8b1c.zip
New ebuild for bug 233738.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/igmpproxy/ChangeLog11
-rw-r--r--net-misc/igmpproxy/files/igmpproxy-conf.d6
-rw-r--r--net-misc/igmpproxy/files/igmpproxy-init.d25
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1_beta3.ebuild23
-rw-r--r--net-misc/igmpproxy/metadata.xml13
5 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/ChangeLog b/net-misc/igmpproxy/ChangeLog
new file mode 100644
index 000000000000..853b139f2140
--- /dev/null
+++ b/net-misc/igmpproxy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/igmpproxy
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/igmpproxy/ChangeLog,v 1.1 2009/05/03 20:05:13 idl0r Exp $
+
+*igmpproxy-0.1_beta3 (03 May 2009)
+
+ 03 May 2009; Christian Ruppert <idl0r@gentoo.org>
+ +igmpproxy-0.1_beta3.ebuild, +files/igmpproxy-conf.d,
+ +files/igmpproxy-init.d, +metadata.xml:
+ New ebuild for bug 233738.
+
diff --git a/net-misc/igmpproxy/files/igmpproxy-conf.d b/net-misc/igmpproxy/files/igmpproxy-conf.d
new file mode 100644
index 000000000000..a7a2b348d2a5
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy-conf.d
@@ -0,0 +1,6 @@
+# Specify a configuration file
+IGMPPROXY_CONFIG="/etc/igmpproxy.conf"
+
+# Additional command line options.
+# See igmpproxy(8) for more information.
+IGMPPROXY_OPTS=""
diff --git a/net-misc/igmpproxy/files/igmpproxy-init.d b/net-misc/igmpproxy/files/igmpproxy-init.d
new file mode 100644
index 000000000000..8a117e91d27b
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy-init.d
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/igmpproxy/files/igmpproxy-init.d,v 1.1 2009/05/03 20:05:14 idl0r Exp $
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting IGMPproxy"
+ start-stop-daemon --start --background \
+ --make-pidfile --pidfile /var/run/igmpproxy.pid \
+ --exec /usr/sbin/igmpproxy -- \
+ ${IGMPPROXY_OPTS} "${IGMPPROXY_CONFIG:-/etc/igmpproxy.conf}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping IGMPproxy"
+ start-stop-daemon --stop --pidfile /var/run/igmpproxy.pid
+ eend $?
+}
+
diff --git a/net-misc/igmpproxy/igmpproxy-0.1_beta3.ebuild b/net-misc/igmpproxy/igmpproxy-0.1_beta3.ebuild
new file mode 100644
index 000000000000..0c411f09d9c6
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1_beta3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/igmpproxy/igmpproxy-0.1_beta3.ebuild,v 1.1 2009/05/03 20:05:13 idl0r Exp $
+
+inherit linux-info
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
+HOMEPAGE="http://sourceforge.net/projects/igmpproxy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CONFIG_CHECK="IP_MULTICAST IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN} || die
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN} || die
+}
diff --git a/net-misc/igmpproxy/metadata.xml b/net-misc/igmpproxy/metadata.xml
new file mode 100644
index 000000000000..e01fa5a3fa5b
--- /dev/null
+++ b/net-misc/igmpproxy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <longdescription>
+ IGMPproxy is a simple dynamic Multicast Routing Daemon using only IGMP signalling.
+ It's intended for simple forwarding of Multicast traffic between networks.
+ </longdescription>
+</pkgmetadata>