summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-10-06 09:54:11 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-10-06 09:54:11 +0000
commit49155bca009bcb81dedc6b9b13024a2379635c15 (patch)
treed612a572614adb72e10c4a231c06ad1201816236 /net-misc
parentMissing texinfo DEPEND. (diff)
downloadgentoo-2-49155bca009bcb81dedc6b9b13024a2379635c15.tar.gz
gentoo-2-49155bca009bcb81dedc6b9b13024a2379635c15.tar.bz2
gentoo-2-49155bca009bcb81dedc6b9b13024a2379635c15.zip
Fix bug #287746, compile-warnings support was automagic, which forced -Werror cflag to be used (and compilation to fail). Fix some QA
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/drivel/ChangeLog7
-rw-r--r--net-misc/drivel/drivel-3.0.0.ebuild32
-rw-r--r--net-misc/drivel/files/drivel-3.0.0-compile-warnings.patch25
3 files changed, 51 insertions, 13 deletions
diff --git a/net-misc/drivel/ChangeLog b/net-misc/drivel/ChangeLog
index 9f5ec3834413..331002a30b3e 100644
--- a/net-misc/drivel/ChangeLog
+++ b/net-misc/drivel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/drivel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/ChangeLog,v 1.34 2009/10/05 18:55:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/ChangeLog,v 1.35 2009/10/06 09:54:11 mrpouet Exp $
+
+ 06 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+ drivel-3.0.0.ebuild, +files/drivel-3.0.0-compile-warnings.patch:
+ Fix bug #287746, compile-warnings support was automagic, which forced
+ -Werror cflag to be used (and compilation to fail). Fix some QA.
05 Oct 2009; Hans de Graaff <graaff@gentoo.org> drivel-3.0.0.ebuild:
Do not error out on warnings, this should fix the build as reported in
diff --git a/net-misc/drivel/drivel-3.0.0.ebuild b/net-misc/drivel/drivel-3.0.0.ebuild
index bfab44d92633..d161e2958d4f 100644
--- a/net-misc/drivel/drivel-3.0.0.ebuild
+++ b/net-misc/drivel/drivel-3.0.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-3.0.0.ebuild,v 1.2 2009/10/05 18:55:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-3.0.0.ebuild,v 1.3 2009/10/06 09:54:11 mrpouet Exp $
-inherit gnome2
+EAPI="2"
+
+inherit autotools eutils gnome2
DESCRIPTION="Drivel is a desktop blogger with support for LiveJournal, Blogger,
MoveableType, Wordpress and more."
@@ -29,15 +31,21 @@ DEPEND="${RDEPEND}
>=app-text/gnome-doc-utils-0.3.2
>=dev-util/intltool-0.21
>=app-text/scrollkeeper-0.3.5"
-
DOCS="AUTHORS ChangeLog NEWS README TODO"
-G2CONF="${G2CONF} \
- `use_with spell gtkspell` \
- `use_with dbus` \
- --disable-mime-update \
- --disable-desktop-update \
- --disable-error-on-warning \
- --localstatedir=${D}/var"
-
-USE_DESTDIR="1"
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with spell gtkspell)
+ $(use_with dbus)
+ --disable-mime-update
+ --disable-desktop-update
+ --disable-error-on-warning
+ --disable-compile-warnings
+ --localstatedir=${D}/var"
+}
+src_prepare() {
+ epatch "${FILESDIR}/${P}-compile-warnings.patch"
+
+ intltoolize --automake --copy --force || die "intltoolize failed"
+ eautoreconf
+}
diff --git a/net-misc/drivel/files/drivel-3.0.0-compile-warnings.patch b/net-misc/drivel/files/drivel-3.0.0-compile-warnings.patch
new file mode 100644
index 000000000000..0d691241dc12
--- /dev/null
+++ b/net-misc/drivel/files/drivel-3.0.0-compile-warnings.patch
@@ -0,0 +1,25 @@
+From 0aad8e2d49567c78f0c0bd43ecc2547a7a9f3e7e Mon Sep 17 00:00:00 2001
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Tue, 6 Oct 2009 11:41:11 +0200
+Subject: [PATCH] Fix compile-warnings automagic support, which caused compilation to fail (-Werror)
+
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4d83014..8500f3b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -238,7 +238,7 @@ set_compile_warnings=no
+ AC_ARG_ENABLE(compile-warnings,
+ [ --enable-compile-warnings
+ Enable verbose compiler warnings],
+- set_compile_warnings=yes)
++ set_compile_warnings=$enableval, set_compile_warnings=yes)
+
+ if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
+ WARN_CFLAGS="$WARN_CFLAGS -Wcast-align -Wsign-compare \
+--
+1.6.5.rc2
+