summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-03-16 13:45:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-03-16 13:45:00 +0000
commit1ed975fda176ce8bd21dacce9a9f856315875226 (patch)
tree296d2444be339630144e5f9554c052bd5d636bcc /net-misc
parentstable amd64, bug 262620 (diff)
downloadgentoo-2-1ed975fda176ce8bd21dacce9a9f856315875226.tar.gz
gentoo-2-1ed975fda176ce8bd21dacce9a9f856315875226.tar.bz2
gentoo-2-1ed975fda176ce8bd21dacce9a9f856315875226.zip
More Flameeyes-inspired --as-needed fixing, the NET-SNMP configure test was passing libraries in LDFLAGS and failed quite horribly. Patch added without revision bump, if this hit you the software failed to configure entirely. Reported upstream.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk/ChangeLog10
-rw-r--r--net-misc/asterisk/asterisk-1.6.0.6.ebuild9
-rw-r--r--net-misc/asterisk/files/1.6.0/asterisk-1.6.0.6-toolcheck-libs-not-ldflags.patch23
3 files changed, 40 insertions, 2 deletions
diff --git a/net-misc/asterisk/ChangeLog b/net-misc/asterisk/ChangeLog
index d3ac53223403..16c43ace323c 100644
--- a/net-misc/asterisk/ChangeLog
+++ b/net-misc/asterisk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/asterisk
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.188 2009/03/15 15:12:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.189 2009/03/16 13:45:00 chainsaw Exp $
+
+ 16 Mar 2009; <chainsaw@gentoo.org>
+ +files/1.6.0/asterisk-1.6.0.6-toolcheck-libs-not-ldflags.patch,
+ asterisk-1.6.0.6.ebuild:
+ More Flameeyes-inspired --as-needed fixing, the NET-SNMP configure test
+ was passing libraries in LDFLAGS and failed quite horribly. Patch added
+ without revision bump, if this hit you the software failed to configure
+ entirely. Reported upstream.
15 Mar 2009; Markus Meier <maekke@gentoo.org> asterisk-1.2.31.1.ebuild:
amd64/x86 stable, bug #250748
diff --git a/net-misc/asterisk/asterisk-1.6.0.6.ebuild b/net-misc/asterisk/asterisk-1.6.0.6.ebuild
index d81b0949af76..db4d6c9442dc 100644
--- a/net-misc/asterisk/asterisk-1.6.0.6.ebuild
+++ b/net-misc/asterisk/asterisk-1.6.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.0.6.ebuild,v 1.1 2009/03/10 23:33:28 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.0.6.ebuild,v 1.2 2009/03/16 13:45:00 chainsaw Exp $
EAPI=1
inherit eutils autotools
@@ -199,6 +199,13 @@ src_unpack() {
epatch "${FILESDIR}"/1.6.0/${P}-parallelmake.patch || die "patch failed"
#
+ # do not try to pass libraries in ldflags but use libs properly
+ # keeps NET-SNMP configure test from failing horribly on --as-needed
+ # patch credit: Diego E. 'Flameeyes' Pettenò <flameeyes@entoo.org>
+ #
+ epatch "${FILESDIR}"/1.6.0/${P}-toolcheck-libs-not-ldflags.patch || die "patch failed"
+
+ #
# the build system didn't handle >= autoconf-2.62 before
# from upstream SVN commit rev 180946 by qwell
#
diff --git a/net-misc/asterisk/files/1.6.0/asterisk-1.6.0.6-toolcheck-libs-not-ldflags.patch b/net-misc/asterisk/files/1.6.0/asterisk-1.6.0.6-toolcheck-libs-not-ldflags.patch
new file mode 100644
index 000000000000..3900a5293073
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.0/asterisk-1.6.0.6-toolcheck-libs-not-ldflags.patch
@@ -0,0 +1,23 @@
+diff -uNr asterisk-1.6.0.6.ORIG/autoconf/ast_ext_tool_check.m4 asterisk-1.6.0.6/autoconf/ast_ext_tool_check.m4
+--- asterisk-1.6.0.6.ORIG/autoconf/ast_ext_tool_check.m4 2009-03-16 13:17:33.000000000 +0000
++++ asterisk-1.6.0.6/autoconf/ast_ext_tool_check.m4 2009-03-16 13:18:26.000000000 +0000
+@@ -20,8 +20,8 @@
+ fi
+ CPPFLAGS="${CPPFLAGS} ${$1_INCLUDE}"
+
+- saved_ldflags="${LDFLAGS}"
+- LDFLAGS="${$1_LIB}"
++ saved_libs="${LIBS}"
++ LIBS="${$1_LIB}"
+
+ AC_LINK_IFELSE(
+ [ AC_LANG_PROGRAM( [ $5 ],
+@@ -33,7 +33,7 @@
+ []
+ )
+ CPPFLAGS="${saved_cppflags}"
+- LDFLAGS="${saved_ldflags}"
++ LIBS="${saved_libs}"
+ else
+ PBX_$1=1
+ AC_DEFINE([HAVE_$1], 1, [Define if your system has the $1 libraries.])