summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-26 20:02:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-26 20:02:10 +0000
commit1a6cc9dc31e0736ab9ab0791c115a0ad1ed7ac46 (patch)
tree05e27bfff2339b5d397c44c1b5e0871e9082ddd2 /net-misc
parentJust signing. (diff)
downloadgentoo-2-1a6cc9dc31e0736ab9ab0791c115a0ad1ed7ac46.tar.gz
gentoo-2-1a6cc9dc31e0736ab9ab0791c115a0ad1ed7ac46.tar.bz2
gentoo-2-1a6cc9dc31e0736ab9ab0791c115a0ad1ed7ac46.zip
Patch from Dane Smith <smithdanea@gmail.com> which fixes LDFLAGS (bug #334461), adding missing || dies and other QA fixes
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netpipe/ChangeLog11
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild30
2 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/netpipe/ChangeLog b/net-misc/netpipe/ChangeLog
index b2fdaa1724f7..c80594372d31 100644
--- a/net-misc/netpipe/ChangeLog
+++ b/net-misc/netpipe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/netpipe
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/ChangeLog,v 1.9 2007/09/29 12:56:05 coldwind Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/ChangeLog,v 1.10 2010/08/26 20:02:10 hwoarang Exp $
+
+*netpipe-1.0.0_beta2-r1 (26 Aug 2010)
+
+ 26 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +netpipe-1.0.0_beta2-r1.ebuild:
+ Patch from Dane Smith <smithdanea@gmail.com> which fixes LDFLAGS (bug
+ #334461), adding missing || dies and other QA fixes
29 Sep 2007; Santiago M. Mola <coldwind@gentoo.org>
netpipe-1.0.0_beta2.ebuild:
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild
new file mode 100644
index 000000000000..e472ef81949d
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild,v 1.1 2010/08/26 20:02:10 hwoarang Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+HOMEPAGE="http://www.wudika.de/~jan/netpipe/"
+SRC_URI="http://www.wudika.de/~jan/${PN}/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS} ${LDFLAGS}:" \
+ -e "s:^CC=.*:CC = $(tc-getCC):" \
+ Makefile || die "sed failed"
+}
+
+src_install() {
+ dobin netpipe || die "dobin failed"
+ dodoc DOCUMENTATION INSTALL TECH-NOTES || die
+}