summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-22 16:22:11 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-22 16:22:11 +0000
commit1860fa8a7852e069757b93977a25e2f25d880563 (patch)
treeac3d01d4a1a0a1f02e000062e1061176c03bf12c /net-misc
parentfixed chroot permissions (diff)
downloadgentoo-2-1860fa8a7852e069757b93977a25e2f25d880563.tar.gz
gentoo-2-1860fa8a7852e069757b93977a25e2f25d880563.tar.bz2
gentoo-2-1860fa8a7852e069757b93977a25e2f25d880563.zip
* bump, closing bug #145414.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.15.5.ebuild95
-rw-r--r--net-misc/curl/files/digest-curl-7.15.53
3 files changed, 105 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 0827cf145ff5..2d2ef97ce560 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.77 2006/10/04 17:45:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.78 2006/10/22 16:22:11 voxus Exp $
+
+*curl-7.15.5 (22 Oct 2006)
+
+ 22 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +curl-7.15.5.ebuild:
+ Version bump, closing bug #145414.
04 Oct 2006; Fabian Groffen <grobian@gentoo.org> curl-7.15.1-r1.ebuild,
curl-7.15.3.ebuild, curl-7.15.4.ebuild:
diff --git a/net-misc/curl/curl-7.15.5.ebuild b/net-misc/curl/curl-7.15.5.ebuild
new file mode 100644
index 000000000000..87056a3ed31a
--- /dev/null
+++ b/net-misc/curl/curl-7.15.5.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.5.ebuild,v 1.1 2006/10/22 16:22:11 voxus Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit libtool eutils
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ipv6 ldap ares gnutls idn kerberos krb4 test"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ ssl? ( !gnutls? ( dev-libs/openssl ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( net-dns/c-ares )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )"
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-7.15-strip-ldflags.patch
+ elibtoolize
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_with idn libidn)
+ $(use_enable kerberos gssapi)
+ $(use_enable ipv6)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile"
+
+ if use ipv6 && use ares; then
+ ewarn "c-ares support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-ares"
+ else
+ myconf="${myconf} $(use_enable ares)"
+ fi
+
+ if use ipv6 && use krb4; then
+ ewarn "kerberos-4 support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-krb4"
+ else
+ myconf="${myconf} $(use_enable krb4)"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls=/usr"
+ elif use ssl; then
+ myconf="${myconf} --without-gnutls --with-ssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl"
+ fi
+
+ if use kerberos; then
+ myconf="${myconfg} --with-gssapi=/usr"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installed failed for current version"
+
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/digest-curl-7.15.5 b/net-misc/curl/files/digest-curl-7.15.5
new file mode 100644
index 000000000000..201be43dcabf
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.15.5
@@ -0,0 +1,3 @@
+MD5 594142c7d53bbdd988e8cef6354eeeff curl-7.15.5.tar.bz2 1543007
+RMD160 4494cffb382c81b7211830c7e6e40ef9ed8f4ef0 curl-7.15.5.tar.bz2 1543007
+SHA256 2980815e53f4caeafc5e35d183d9379bcaaec49f759be1a4ac628cfb6c392fe0 curl-7.15.5.tar.bz2 1543007