summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-18 03:15:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-18 03:15:31 +0000
commit0cae36fc2b052ae7b394d8e44e89c5a51c8daeb9 (patch)
tree3c5b6ccdebe04bccea67d9be2262fa8b8bb2b6dd /net-misc
parentinitial ebuild #42476 (diff)
downloadgentoo-2-0cae36fc2b052ae7b394d8e44e89c5a51c8daeb9.tar.gz
gentoo-2-0cae36fc2b052ae7b394d8e44e89c5a51c8daeb9.tar.bz2
gentoo-2-0cae36fc2b052ae7b394d8e44e89c5a51c8daeb9.zip
make sure we add the dhcp user #44599
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/udhcp/udhcp-0.9.8-r2.ebuild16
-rw-r--r--net-misc/udhcp/udhcp-0.9.8-r3.ebuild16
2 files changed, 19 insertions, 13 deletions
diff --git a/net-misc/udhcp/udhcp-0.9.8-r2.ebuild b/net-misc/udhcp/udhcp-0.9.8-r2.ebuild
index 90bd55e143a0..7c2b99533af0 100644
--- a/net-misc/udhcp/udhcp-0.9.8-r2.ebuild
+++ b/net-misc/udhcp/udhcp-0.9.8-r2.ebuild
@@ -1,29 +1,31 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/udhcp-0.9.8-r2.ebuild,v 1.1 2004/03/08 23:51:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/udhcp-0.9.8-r2.ebuild,v 1.2 2004/03/18 03:15:31 vapier Exp $
-IUSE=""
+inherit eutils
DESCRIPTION="udhcp Server/Client Package"
HOMEPAGE="http://udhcp.busybox.net/"
SRC_URI="http://udhcp.busybox.net/source/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 sparc amd64"
DEPEND="virtual/glibc"
-
PROVIDE="virtual/dhcpc"
+pkg_setup() {
+ enewgroup dhcp
+ enewuser dhcp -1 /bin/false /var/lib/dhcp dhcp
+}
+
src_compile() {
emake SYSLOG=1 || die
}
src_install() {
- dodir /usr/sbin
- dodir /usr/bin
- dodir /sbin
+ dodir /usr/sbin /usr/bin /sbin
insinto /etc
doins samples/udhcpd.conf
diff --git a/net-misc/udhcp/udhcp-0.9.8-r3.ebuild b/net-misc/udhcp/udhcp-0.9.8-r3.ebuild
index 5e6ffb5755b6..c56eb80334af 100644
--- a/net-misc/udhcp/udhcp-0.9.8-r3.ebuild
+++ b/net-misc/udhcp/udhcp-0.9.8-r3.ebuild
@@ -1,27 +1,31 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/udhcp-0.9.8-r3.ebuild,v 1.3 2004/03/11 15:11:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/udhcp-0.9.8-r3.ebuild,v 1.4 2004/03/18 03:15:31 vapier Exp $
+
+inherit eutils
DESCRIPTION="udhcp Server/Client Package"
HOMEPAGE="http://udhcp.busybox.net/"
SRC_URI="http://udhcp.busybox.net/source/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 amd64"
DEPEND="virtual/glibc"
-
PROVIDE="virtual/dhcpc"
+pkg_setup() {
+ enewgroup dhcp
+ enewuser dhcp -1 /bin/false /var/lib/dhcp dhcp
+}
+
src_compile() {
emake SYSLOG=1 || die
}
src_install() {
- dodir /usr/sbin
- dodir /usr/bin
- dodir /sbin
+ dodir /usr/sbin /usr/bin /sbin
insinto /etc
doins samples/udhcpd.conf