summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:19:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:19:39 +0000
commitdcd9dced114f503989d1d0a3fc249f0520c4ae63 (patch)
tree6a51e09adf378d6b2eff84698553a305bc856f26 /net-misc/tsclient
parentVersion 2.2.2 does not build with kde-4.6 (diff)
downloadgentoo-2-dcd9dced114f503989d1d0a3fc249f0520c4ae63.tar.gz
gentoo-2-dcd9dced114f503989d1d0a3fc249f0520c4ae63.tar.bz2
gentoo-2-dcd9dced114f503989d1d0a3fc249f0520c4ae63.zip
Fix missing depend and building with x11-libs/libnotify >= 0.7 wrt #357087 by Martin LORANG.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tsclient')
-rw-r--r--net-misc/tsclient/ChangeLog9
-rw-r--r--net-misc/tsclient/files/tsclient-2.0.1-libnotify-0.7.patch54
-rw-r--r--net-misc/tsclient/tsclient-2.0.1.ebuild10
3 files changed, 67 insertions, 6 deletions
diff --git a/net-misc/tsclient/ChangeLog b/net-misc/tsclient/ChangeLog
index 35212c793d30..fa8a1f687a45 100644
--- a/net-misc/tsclient/ChangeLog
+++ b/net-misc/tsclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tsclient
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/ChangeLog,v 1.33 2010/11/02 02:55:05 ford_prefect Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/ChangeLog,v 1.34 2011/03/13 08:19:39 ssuominen Exp $
+
+ 13 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> tsclient-2.0.1.ebuild,
+ +files/tsclient-2.0.1-libnotify-0.7.patch:
+ Fix missing depend and building with x11-libs/libnotify >= 0.7 wrt #357087 by
+ Martin LORANG.
02 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
tsclient-2.0.1.ebuild:
diff --git a/net-misc/tsclient/files/tsclient-2.0.1-libnotify-0.7.patch b/net-misc/tsclient/files/tsclient-2.0.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..351f3fb16a05
--- /dev/null
+++ b/net-misc/tsclient/files/tsclient-2.0.1-libnotify-0.7.patch
@@ -0,0 +1,54 @@
+--- src/plugins/default/tsc-rdp-connection.c
++++ src/plugins/default/tsc-rdp-connection.c
+@@ -13,6 +13,10 @@
+ #include "tsc-connection.h"
+ #include "tsc-util.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define RDP_CONFIG_GROUP "RDP"
+ #define RDP_KEY_HOST "host"
+ #define RDP_KEY_USERNAME "username"
+@@ -50,7 +54,12 @@
+ tsc_connection_get_name (TSC_CONNECTION (connection)));
+ body = g_strdup_printf (_("You are connected to '%s' in fullscreen mode. Use Control+Alt+Enter to switch to and from windowed mode."), tsc_connection_get_name (TSC_CONNECTION (connection)));
+
+- n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO, NULL);
++ n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ g_free (summary);
+ g_free (body);
+
+--- src/plugins/default/tsc-vnc-connection.c
++++ src/plugins/default/tsc-vnc-connection.c
+@@ -8,6 +8,10 @@
+ #include "tsc-util.h"
+ #include "tsc-connection.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define VNC_CONFIG_GROUP "VNC"
+ #define VNC_KEY_HOST "host"
+ #define VNC_KEY_PASSWORD "password"
+@@ -39,7 +43,12 @@
+ tsc_connection_get_name (TSC_CONNECTION (connection)));
+ body = g_strdup_printf (_("You are connected to '%s' in fullscreen mode. Use F8 to switch to and from windowed mode."), tsc_connection_get_name (TSC_CONNECTION (connection)));
+
+- n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO, NULL);
++ n = notify_notification_new (summary, body, GTK_STOCK_DIALOG_INFO
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ g_free (summary);
+ g_free (body);
+
diff --git a/net-misc/tsclient/tsclient-2.0.1.ebuild b/net-misc/tsclient/tsclient-2.0.1.ebuild
index 1785b76d92fc..5f2871e8ae69 100644
--- a/net-misc/tsclient/tsclient-2.0.1.ebuild
+++ b/net-misc/tsclient/tsclient-2.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/tsclient-2.0.1.ebuild,v 1.3 2010/11/02 02:55:05 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/tsclient-2.0.1.ebuild,v 1.4 2011/03/13 08:19:39 ssuominen Exp $
EAPI=2
@@ -23,7 +23,8 @@ RDEPEND="x11-libs/gtk+:2
gnome-base/libglade:2.0
gnome-base/libgnome
gnome-base/libgnomeui
- gnome-base/gnome-desktop:2"
+ gnome-base/gnome-desktop:2
+ x11-libs/libnotify"
DEPEND="${RDEPEND}
gnome-base/gconf
@@ -34,7 +35,8 @@ RDEPEND="${RDEPEND}
>=net-misc/rdesktop-1.3.0"
src_prepare() {
- epatch "${FILESDIR}"/${P}-no-networkmanager.patch
+ epatch "${FILESDIR}"/${P}-no-networkmanager.patch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
# For recent libgnomeui
sed -i -e 's:libgnome-2\.0:\0 libgnomeui-2\.0:' \