summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-02-28 19:34:07 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-02-28 19:34:07 +0000
commit9bbbd6854cf99ea52ef266f5dd78634d81630339 (patch)
treebb6e6a53fa5d33b7028d382d7c212c3bfeaa97e9 /net-misc/rsync
parentApply patch from Arfrever for bug 406129. Tested by Ian Delaney. (diff)
downloadgentoo-2-9bbbd6854cf99ea52ef266f5dd78634d81630339.tar.gz
gentoo-2-9bbbd6854cf99ea52ef266f5dd78634d81630339.tar.bz2
gentoo-2-9bbbd6854cf99ea52ef266f5dd78634d81630339.zip
revision bump to support Gentoo Prefix. EAPI, KEYWORDS, EPREFIX/ED/EROOT usage, new files in FILESDIR. Bug 406061
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/ChangeLog9
-rw-r--r--net-misc/rsync/files/rsyncd.conf-3.0.9-r115
-rw-r--r--net-misc/rsync/files/rsyncd.xinetd-3.0.9-r110
-rw-r--r--net-misc/rsync/rsync-3.0.9-r1.ebuild69
4 files changed, 102 insertions, 1 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index d2ae573c48f8..15cca424e029 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/rsync
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.216 2012/02/28 18:07:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.217 2012/02/28 19:34:07 darkside Exp $
+
+*rsync-3.0.9-r1 (28 Feb 2012)
+
+ 28 Feb 2012; Jeremy Olexa <darkside@gentoo.org> +files/rsyncd.conf-3.0.9-r1,
+ +files/rsyncd.xinetd-3.0.9-r1, +rsync-3.0.9-r1.ebuild:
+ revision bump to support Gentoo Prefix. EAPI, KEYWORDS, EPREFIX/ED/EROOT
+ usage, new files in FILESDIR. Bug 406061
28 Feb 2012; Jeroen Roovers <jer@gentoo.org> rsync-3.0.9.ebuild:
Stable for HPPA (bug #406055).
diff --git a/net-misc/rsync/files/rsyncd.conf-3.0.9-r1 b/net-misc/rsync/files/rsyncd.conf-3.0.9-r1
new file mode 100644
index 000000000000..168325cd511f
--- /dev/null
+++ b/net-misc/rsync/files/rsyncd.conf-3.0.9-r1
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This line is required by the /etc/init.d/rsyncd script
+pid file = @GENTOO_PORTAGE_EPREFIX@/var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[gentoo-portage]
+# path = @GENTOO_PORTAGE_EPREFIX@/usr/portage
+# comment = Gentoo Portage tree
+# exclude = /distfiles /packages
diff --git a/net-misc/rsync/files/rsyncd.xinetd-3.0.9-r1 b/net-misc/rsync/files/rsyncd.xinetd-3.0.9-r1
new file mode 100644
index 000000000000..90d07f0710ba
--- /dev/null
+++ b/net-misc/rsync/files/rsyncd.xinetd-3.0.9-r1
@@ -0,0 +1,10 @@
+service rsync
+{
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = root
+ server = @GENTOO_PORTAGE_EPREFIX@/usr/bin/rsync
+ server_args = --daemon
+ disable = yes
+}
diff --git a/net-misc/rsync/rsync-3.0.9-r1.ebuild b/net-misc/rsync/rsync-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..ba7af77900b7
--- /dev/null
+++ b/net-misc/rsync/rsync-3.0.9-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.9-r1.ebuild,v 1.1 2012/02/28 19:34:07 darkside Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic prefix
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/src/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl iconv ipv6 static xattr"
+
+DEPEND=">=dev-libs/popt-1.5
+ acl? ( virtual/acl )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ iconv? ( virtual/libiconv )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --without-included-popt \
+ $(use_enable acl acl-support) \
+ $(use_enable xattr xattr-support) \
+ $(use_enable ipv6) \
+ $(use_enable iconv) \
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install the useful contrib scripts
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED}"/usr/share/rsync/{Makefile*,*.c}
+
+ eprefixify "${ED}"/etc/{,xinetd.d}/rsyncd*
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+}