summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-10-29 16:48:19 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-10-29 16:48:19 +0000
commit94981a47811d964132117de84ed95cab792df838 (patch)
tree4badbd9fc8300228ad06259872a9ab81c160baea /net-misc/putty
parentVersion bump. (diff)
downloadgentoo-2-94981a47811d964132117de84ed95cab792df838.tar.gz
gentoo-2-94981a47811d964132117de84ed95cab792df838.tar.bz2
gentoo-2-94981a47811d964132117de84ed95cab792df838.zip
ebuild cleanup, moving the makefile generation into src_unpack()
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog5
-rw-r--r--net-misc/putty/Manifest4
-rw-r--r--net-misc/putty/putty-20030902-r1.ebuild31
3 files changed, 24 insertions, 16 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index f6e4dc632777..48f2af3c9973 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.7 2003/10/07 14:01:09 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.8 2003/10/29 16:48:08 taviso Exp $
+
+ 29 Oct 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030902-r1.ebuild:
+ code cleanups, moving makefile generation into src_unpack()
07 Oct 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030603.ebuild,
putty-20030902-r1.ebuild, putty-20030902.ebuild:
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 71b649972764..41f8d4bee30c 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,4 +1,4 @@
-MD5 81aec9ecf2d889d1339129d7cd01c9ac putty-20030902-r1.ebuild 1380
-MD5 929e219dd8165632a84c3f144277dab1 ChangeLog 1188
+MD5 27c2740c5ab57b401017d35b04b422db putty-20030902-r1.ebuild 1386
+MD5 db5ef4b19662d3734390b67cee9f915a ChangeLog 1326
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 68c88474593f165e89a7cf28fe98f555 files/digest-putty-20030902-r1 70
diff --git a/net-misc/putty/putty-20030902-r1.ebuild b/net-misc/putty/putty-20030902-r1.ebuild
index 5e00a133a61c..cff0d75bb982 100644
--- a/net-misc/putty/putty-20030902-r1.ebuild
+++ b/net-misc/putty/putty-20030902-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20030902-r1.ebuild,v 1.2 2003/10/07 14:01:09 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20030902-r1.ebuild,v 1.3 2003/10/29 16:48:08 taviso Exp $
-DESCRIPTION="UNIX port of the famous Windows Telnet and SSH client"
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
SRC_URI="mirror://gentoo/putty-cvs-${PV}.tar.gz"
@@ -12,25 +12,30 @@ SLOT="0"
KEYWORDS="x86 alpha"
IUSE="doc"
-RDEPEND="=x11-libs/gtk+-1.2*
- virtual/x11"
+RDEPEND="=x11-libs/gtk+-1.2* virtual/x11"
+
DEPEND="${RDEPEND}
>=dev-lang/perl-5.8.0
- >=sys-apps/sed-4
- =x11-libs/gtk+-1.2*
- virtual/x11"
+ >=sys-apps/sed-4"
S=${WORKDIR}/${PN}
-src_compile() {
+src_unpack() {
+ # unpack the tarball...
+ unpack ${A}
+
# generate the makefiles
- einfo "Generating Makefiles..."
- ${S}/mkfiles.pl || die "failed to create makefiles."
+ ebegin "Generating Makefiles"
+ cd ${S}; ${S}/mkfiles.pl
+ eend $?
# change the CFLAGS to those requested by user.
- einfo "Setting CFLAGS..."
- sed -i "s/-O2/${CFLAGS}/g" ${S}/unix/Makefile.gtk
+ ebegin "Setting CFLAGS"
+ sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+ eend $?
+}
+src_compile() {
# build putty.
einfo "Building putty..."
cd ${S}/unix; emake -f Makefile.gtk
@@ -56,7 +61,7 @@ src_install() {
if test ! -c /dev/ptmx; then
ewarn
- ewarn "The pterm application requires UNIX98 PTY support to operate."
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
ewarn
fi
}