summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-04-05 07:48:02 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-04-05 07:48:02 +0000
commitf203b891a951a5f982b9595c34b1b8b2c19910cd (patch)
treec773d1d68a5c9f9ebce772e0baa627ca9fdd65aa /net-misc/netkit-telnetd
parentgcc3 related header file fix (diff)
downloadgentoo-2-f203b891a951a5f982b9595c34b1b8b2c19910cd.tar.gz
gentoo-2-f203b891a951a5f982b9595c34b1b8b2c19910cd.tar.bz2
gentoo-2-f203b891a951a5f982b9595c34b1b8b2c19910cd.zip
fixes to make it compile with gcc3
Diffstat (limited to 'net-misc/netkit-telnetd')
-rw-r--r--net-misc/netkit-telnetd/ChangeLog10
-rw-r--r--net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r2 (renamed from net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r1)0
-rw-r--r--net-misc/netkit-telnetd/files/netkit-telnetd-0.17-gentoo.patch81
-rw-r--r--net-misc/netkit-telnetd/netkit-telnetd-0.17-r2.ebuild (renamed from net-misc/netkit-telnetd/netkit-telnetd-0.17-r1.ebuild)2
4 files changed, 91 insertions, 2 deletions
diff --git a/net-misc/netkit-telnetd/ChangeLog b/net-misc/netkit-telnetd/ChangeLog
index f72913e0961a..11f92d2d669b 100644
--- a/net-misc/netkit-telnetd/ChangeLog
+++ b/net-misc/netkit-telnetd/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-misc/netkit-telnetd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/ChangeLog,v 1.1 2002/02/01 21:53:35 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/ChangeLog,v 1.2 2002/04/05 07:48:02 gbevin Exp $
+*netkit-telnetd-0.17-r2 (05 Apr 2002)
+
+ 05 Apr 2002; G.Bevin <gbevin@gentoo.org> netkit-telnetd-0.17-r2.ebuil,
+ files/netkit-telnetd-0.17-gentoo.patch files/digest-netkit-telnetd-0.17-r2 :
+
+ Global fixes to makefile inclusion and library linkage to make it compile
+ with gcc3.
+
*netkit-telnetd-0.17-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r1 b/net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r2
index 41cd77d8ad6d..41cd77d8ad6d 100644
--- a/net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r1
+++ b/net-misc/netkit-telnetd/files/digest-netkit-telnetd-0.17-r2
diff --git a/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-gentoo.patch b/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-gentoo.patch
new file mode 100644
index 000000000000..d8845baddef8
--- /dev/null
+++ b/net-misc/netkit-telnetd/files/netkit-telnetd-0.17-gentoo.patch
@@ -0,0 +1,81 @@
+diff -r -u netkit-telnet-0.17_orig/telnet/main.cc netkit-telnet-0.17/telnet/main.cc
+--- netkit-telnet-0.17_orig/telnet/main.cc 1999-08-01 07:06:37.000000000 +0200
++++ netkit-telnet-0.17/telnet/main.cc 2002-04-05 09:22:35.000000000 +0200
+@@ -43,6 +43,7 @@
+
+ #include "../version.h"
+
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <getopt.h>
+ #include <string.h>
+diff -r -u netkit-telnet-0.17_orig/telnet/Makefile netkit-telnet-0.17/telnet/Makefile
+--- netkit-telnet-0.17_orig/telnet/Makefile 1999-08-01 07:06:37.000000000 +0200
++++ netkit-telnet-0.17/telnet/Makefile 2002-04-05 09:26:01.000000000 +0200
+@@ -7,7 +7,7 @@
+
+ # -DAUTHENTICATE
+ CXXFLAGS += -DUSE_TERMIO -DKLUDGELINEMODE
+-LIBS += $(LIBTERMCAP)
++LIBS += $(LIBTERMCAP) -lcurses
+
+ SRCS = commands.cc main.cc network.cc ring.cc sys_bsd.cc telnet.cc \
+ terminal.cc tn3270.cc utilities.cc genget.cc environ.cc netlink.cc
+diff -r -u netkit-telnet-0.17_orig/telnet/netlink.cc netkit-telnet-0.17/telnet/netlink.cc
+--- netkit-telnet-0.17_orig/telnet/netlink.cc 2000-07-23 06:16:25.000000000 +0200
++++ netkit-telnet-0.17/telnet/netlink.cc 2002-04-05 09:24:35.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+diff -r -u netkit-telnet-0.17_orig/telnet/network.cc netkit-telnet-0.17/telnet/network.cc
+--- netkit-telnet-0.17_orig/telnet/network.cc 1996-08-13 10:09:58.000000000 +0200
++++ netkit-telnet-0.17/telnet/network.cc 2002-04-05 09:22:52.000000000 +0200
+@@ -37,6 +37,7 @@
+ char net_rcsid[] =
+ "$Id: netkit-telnetd-0.17-gentoo.patch,v 1.1 2002/04/05 07:48:02 gbevin Exp $";
+
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
+diff -r -u netkit-telnet-0.17_orig/telnet/terminal.cc netkit-telnet-0.17/telnet/terminal.cc
+--- netkit-telnet-0.17_orig/telnet/terminal.cc 1999-12-12 20:48:05.000000000 +0100
++++ netkit-telnet-0.17/telnet/terminal.cc 2002-04-05 09:23:53.000000000 +0200
+@@ -41,6 +41,8 @@
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <termios.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <errno.h>
+diff -r -u netkit-telnet-0.17_orig/telnet/utilities.cc netkit-telnet-0.17/telnet/utilities.cc
+--- netkit-telnet-0.17_orig/telnet/utilities.cc 1999-12-12 16:33:40.000000000 +0100
++++ netkit-telnet-0.17/telnet/utilities.cc 2002-04-05 09:24:14.000000000 +0200
+@@ -46,6 +46,8 @@
+ #include <sys/time.h>
+ #include <sys/socket.h>
+ #include <unistd.h>
++#include <string.h>
++#include <stdlib.h>
+ #include <ctype.h>
+
+ #include "ring.h"
+diff -r -u netkit-telnet-0.17_orig/telnetd/Makefile netkit-telnet-0.17/telnetd/Makefile
+--- netkit-telnet-0.17_orig/telnetd/Makefile 1999-12-14 01:43:30.000000000 +0100
++++ netkit-telnet-0.17/telnetd/Makefile 2002-04-05 09:36:47.000000000 +0200
+@@ -10,7 +10,7 @@
+
+ CFLAGS += '-DISSUE_FILE="/etc/issue.net"' -DPARANOID_TTYS \
+ -DNO_REVOKE -DKLUDGELINEMODE -DDIAGNOSTICS
+-# LIBS += $(LIBTERMCAP)
++LIBS += -lutil
+
+ OBJS = telnetd.o state.o termstat.o slc.o sys_term.o utility.o \
+ global.o setproctitle.o
diff --git a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r1.ebuild b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r2.ebuild
index fef1b4589315..03149036739d 100644
--- a/net-misc/netkit-telnetd/netkit-telnetd-0.17-r1.ebuild
+++ b/net-misc/netkit-telnetd/netkit-telnetd-0.17-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r1.ebuild,v 1.7 2002/02/19 02:52:58 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r2.ebuild,v 1.1 2002/04/05 07:48:02 gbevin Exp $
P2=netkit-telnet-${PV}
S=${WORKDIR}/${P2}