summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-27 20:43:24 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-27 20:43:24 +0000
commit23877a20bce661a6446cc060acb111f77b3edd66 (patch)
treecbeff3e0082bc6f7d87ebdf009cefa1dd5793519 /net-misc/neon
parentSecurity bug #205346 (diff)
downloadgentoo-2-23877a20bce661a6446cc060acb111f77b3edd66.tar.gz
gentoo-2-23877a20bce661a6446cc060acb111f77b3edd66.tar.bz2
gentoo-2-23877a20bce661a6446cc060acb111f77b3edd66.zip
fix #205959
(Portage version: 2.1.4)
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog6
-rw-r--r--net-misc/neon/files/neon-0.27.2-linguas.patch42
-rw-r--r--net-misc/neon/neon-0.27.2.ebuild9
3 files changed, 54 insertions, 3 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 7b76dcc250ea..0d03c3aa1f2f 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.98 2008/01/27 19:27:34 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.99 2008/01/27 20:43:23 hollow Exp $
+
+ 27 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ +files/neon-0.27.2-linguas.patch, neon-0.27.2.ebuild:
+ fix #205959
*neon-0.27.2 (27 Jan 2008)
diff --git a/net-misc/neon/files/neon-0.27.2-linguas.patch b/net-misc/neon/files/neon-0.27.2-linguas.patch
new file mode 100644
index 000000000000..7560a2ce2797
--- /dev/null
+++ b/net-misc/neon/files/neon-0.27.2-linguas.patch
@@ -0,0 +1,42 @@
+Index: neon-0.27.2/Makefile.in
+===================================================================
+--- neon-0.27.2.orig/Makefile.in
++++ neon-0.27.2/Makefile.in
+@@ -181,8 +181,10 @@ install-nls-no:
+
+ install-nls-yes:
+ @for f in $(LINGUAS); do \
+- $(INSTALL) -d $(DESTDIR)$(localedir)/$$f/LC_MESSAGES; \
+- $(INSTALL_DATA) $(srcdir)/po/$$f.gmo $(DESTDIR)$(localedir)/$$f/LC_MESSAGES/neon.mo; \
++ if test -e $(srcdir)/po/$$f.gmo; then \
++ $(INSTALL) -d $(DESTDIR)$(localedir)/$$f/LC_MESSAGES; \
++ $(INSTALL_DATA) $(srcdir)/po/$$f.gmo $(DESTDIR)$(localedir)/$$f/LC_MESSAGES/neon.mo; \
++ fi \
+ done
+
+ ChangeLog:
+@@ -191,15 +193,19 @@ ChangeLog:
+ update-po:
+ @xgettext $(XGETTEXT_OPTS) $(top_srcdir)/src/ne*.c -o $(POTFILE)
+ @for f in $(LINGUAS); do \
+- echo "> Updating \"$$f\" catalog:"; \
+- $(MSGMERGE) --update $(top_srcdir)/po/$$f.po $(POTFILE); \
+- $(MSGFMT) --output /dev/null --check-format $(top_srcdir)/po/$$f.po || exit 1; \
++ if test -e $(srcdir)/po/$$f.gmo; then \
++ echo "> Updating \"$$f\" catalog:"; \
++ $(MSGMERGE) --update $(top_srcdir)/po/$$f.po $(POTFILE); \
++ $(MSGFMT) --output /dev/null --check-format $(top_srcdir)/po/$$f.po || exit 1; \
++ fi \
+ done
+
+ compile-gmo:
+ @for f in $(LINGUAS); do \
+- echo "> Compiling \"$$f\" catalog:"; \
+- $(MSGFMT) --statistics -c -o po/$$f.gmo $(top_srcdir)/po/$$f.po; \
++ if test -e $(srcdir)/po/$$f.gmo; then \
++ echo "> Compiling \"$$f\" catalog:"; \
++ $(MSGFMT) --statistics -c -o po/$$f.gmo $(top_srcdir)/po/$$f.po; \
++ fi \
+ done
+
+ doc-status:
diff --git a/net-misc/neon/neon-0.27.2.ebuild b/net-misc/neon/neon-0.27.2.ebuild
index 6070d3ad63fd..70914b6ab7b5 100644
--- a/net-misc/neon/neon-0.27.2.ebuild
+++ b/net-misc/neon/neon-0.27.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.27.2.ebuild,v 1.1 2008/01/27 19:27:34 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.27.2.ebuild,v 1.2 2008/01/27 20:43:23 hollow Exp $
inherit eutils libtool versionator autotools
@@ -24,7 +24,12 @@ DEPEND="expat? ( dev-libs/expat )
src_unpack() {
unpack ${A}
- elibtoolize
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-linguas.patch
+ sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${LINGUAS}\"/g" \
+ ./configure.in
+ AT_M4DIR=./macros eautoreconf
}
src_compile() {