summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-03-15 02:40:52 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-03-15 02:40:52 +0000
commit37a884de97a07af475bdca3cef6744544ceb6b99 (patch)
treea0bd4e89bcd4e6237d2c4efca426567a2a35f51d /net-misc/gwibber/gwibber-2.29.92.1.ebuild
parentRemoved older version. (diff)
downloadgentoo-2-37a884de97a07af475bdca3cef6744544ceb6b99.tar.gz
gentoo-2-37a884de97a07af475bdca3cef6744544ceb6b99.tar.bz2
gentoo-2-37a884de97a07af475bdca3cef6744544ceb6b99.zip
Version bump. Closes bug #304341
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'net-misc/gwibber/gwibber-2.29.92.1.ebuild')
-rw-r--r--net-misc/gwibber/gwibber-2.29.92.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/gwibber/gwibber-2.29.92.1.ebuild b/net-misc/gwibber/gwibber-2.29.92.1.ebuild
new file mode 100644
index 000000000000..e8ff84f5bb3a
--- /dev/null
+++ b/net-misc/gwibber/gwibber-2.29.92.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwibber/gwibber-2.29.92.1.ebuild,v 1.1 2010/03/15 02:40:52 neurogeek Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils distutils
+
+DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed
+with Python and GTK."
+HOMEPAGE="https://launchpad.net/gwibber"
+SRC_URI="http://launchpad.net/gwibber/2.30/2.29.92/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/dbus-python-0.80.2
+ >=dev-python/gconf-python-2.18.0
+ >=dev-python/imaging-1.1.6
+ >=dev-python/notify-python-0.1.1
+ >=dev-python/pywebkitgtk-1.0.1
+ >=dev-python/simplejson-1.9.1
+ >=dev-python/egenix-mx-base-3.0.0
+ >=dev-python/python-distutils-extra-2.15
+ >=dev-python/pycurl-7.19.0
+ >=dev-python/libwnck-python-2.26.0
+ >=dev-python/feedparser-4.1
+ >=dev-python/pyxdg-0.15
+ >=dev-python/mako-0.2.4
+ >=dev-db/desktopcouch-0.4.6
+ >=dev-python/pygtk-2.16
+ >=gnome-base/librsvg-2.22.2"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins com.Gwibber{.Service,Client}.service || die "Installing services failed."
+ doman gwibber{,-poster}.1 || die "Man page couldn't be installed."
+}