summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-05-26 21:32:51 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-05-26 21:32:51 +0000
commitc15bbf471dc478e6c31ecd8322258cf361b59f71 (patch)
tree02ca13aa1df78d8e311c14db7e27eb6bb4dd3d80 /net-misc/dyndnsupdate
parentVersion bumped. Closes #17546. (diff)
downloadgentoo-2-c15bbf471dc478e6c31ecd8322258cf361b59f71.tar.gz
gentoo-2-c15bbf471dc478e6c31ecd8322258cf361b59f71.tar.bz2
gentoo-2-c15bbf471dc478e6c31ecd8322258cf361b59f71.zip
using the new ccc eclass
Diffstat (limited to 'net-misc/dyndnsupdate')
-rw-r--r--net-misc/dyndnsupdate/Manifest2
-rw-r--r--net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild8
2 files changed, 6 insertions, 4 deletions
diff --git a/net-misc/dyndnsupdate/Manifest b/net-misc/dyndnsupdate/Manifest
index c911b82476cf..4e18d3b1358e 100644
--- a/net-misc/dyndnsupdate/Manifest
+++ b/net-misc/dyndnsupdate/Manifest
@@ -1,3 +1,3 @@
-MD5 6e9189d2617c2edd9764d497b161b723 dyndnsupdate-0.6.14.ebuild 847
+MD5 ea05504d34a4df97626e7ab03887b537 dyndnsupdate-0.6.14.ebuild 853
MD5 1539d86e28fe75bb87040b1f7685680d ChangeLog 583
MD5 febb5d5f01263c91c8378f4deef77568 files/digest-dyndnsupdate-0.6.14 70
diff --git a/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild b/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
index e69352b298c2..68579dd0f39a 100644
--- a/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
+++ b/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild,v 1.5 2003/05/25 17:34:38 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild,v 1.6 2003/05/26 21:32:44 taviso Exp $
+
+inherit ccc
DESCRIPTION="updates the DNS for your hostname/hostnames and other variables at dyndns.org"
SRC_URI="http://xzabite.org/dyndnsupdate/${P}.tar.gz"
@@ -13,8 +15,8 @@ DEPEND=""
src_compile() {
cp Makefile Makefile.old
- sed -e "s/^\(CFLAGS = \).*/\1$CFLAGS/" \
- -e "s/^\(CC=\)gcc/\1${CC:-gcc}/" Makefile.old > Makefile
+ sed -e "s/^\(CFLAGS = \).*/\1$CFLAGS/" Makefile.old > Makefile
+ is-ccc && replace-cc-hardcode
emake || die "Failed to compile."
}