summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-09 04:25:46 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-09 04:25:46 +0000
commit8f0f1e9223c8983a6b1558b5bdec6cd970880af7 (patch)
treead1aa9f6d77d4a8a6e3fa71eda63efbfefac4488 /net-mail
parentInitial import. (diff)
downloadgentoo-2-8f0f1e9223c8983a6b1558b5bdec6cd970880af7.tar.gz
gentoo-2-8f0f1e9223c8983a6b1558b5bdec6cd970880af7.tar.bz2
gentoo-2-8f0f1e9223c8983a6b1558b5bdec6cd970880af7.zip
Version bump.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tmda/ChangeLog7
-rw-r--r--net-mail/tmda/files/digest-tmda-0.711
-rw-r--r--net-mail/tmda/tmda-0.71.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 2e86ce3088a7..69ad6d806cbe 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.28 2003/02/23 08:14:16 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.29 2003/03/09 04:25:46 agenkin Exp $
+
+*tmda-0.71 ( 08 Mar 2003 )
+
+ 08 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Updated to 0.71.
*tmda-0.70 ( 23 Feb 2003 )
diff --git a/net-mail/tmda/files/digest-tmda-0.71 b/net-mail/tmda/files/digest-tmda-0.71
new file mode 100644
index 000000000000..bc732386c77e
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.71
@@ -0,0 +1 @@
+MD5 1561f80fab2900d11027e2b5880a8d77 tmda-0.71.tgz 325723
diff --git a/net-mail/tmda/tmda-0.71.ebuild b/net-mail/tmda/tmda-0.71.ebuild
new file mode 100644
index 000000000000..11ec818aac17
--- /dev/null
+++ b/net-mail/tmda/tmda-0.71.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.71.ebuild,v 1.1 2003/03/09 04:25:46 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.1
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe printcdb printdbm collectaddys def2html \
+ vadduser-tmda vipmap-to-authmap vmailmgr-vdir.sh vpopmail-vdir.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins vtmdarc tmda.el sample.config tmda.spec
+
+ # Not sure what's the best thing to do with tmda-cgi.
+ # For now, installing it in a tarball under /usr/lib/tmda/contrib.
+ tar cjf cgi.tar.bz2 cgi
+ doins cgi.tar.bz2
+}
+
+pkg_postinst () {
+ einfo
+ einfo "The tmda-cgi stuff has been installed in /usr/lib/tmda-cgi.tar.bz2."
+ einfo "Refer to the README file, included in the tarball."
+ einfo
+}