summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-19 06:04:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-19 06:04:33 +0000
commit654d38fe9c7688c568ea39527e049cc5af8649a6 (patch)
tree628c20c09efc1333a21c6d1231cfd07b566cff3b /net-mail
parentremove old stuff (Manifest recommit) (diff)
downloadgentoo-2-654d38fe9c7688c568ea39527e049cc5af8649a6.tar.gz
gentoo-2-654d38fe9c7688c568ea39527e049cc5af8649a6.tar.bz2
gentoo-2-654d38fe9c7688c568ea39527e049cc5af8649a6.zip
dont access $CC
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/ezmlm/ezmlm-0.53-r1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/net-mail/ezmlm/ezmlm-0.53-r1.ebuild b/net-mail/ezmlm/ezmlm-0.53-r1.ebuild
index ca115ce29c36..f952947be86d 100644
--- a/net-mail/ezmlm/ezmlm-0.53-r1.ebuild
+++ b/net-mail/ezmlm/ezmlm-0.53-r1.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm/ezmlm-0.53-r1.ebuild,v 1.4 2004/05/30 10:56:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm/ezmlm-0.53-r1.ebuild,v 1.5 2004/06/19 06:04:33 vapier Exp $
-inherit eutils fixheadtails
+inherit eutils fixheadtails gcc
-DESCRIPTION="Simple yet powerful mailing list manager for qmail."
-SRC_URI="http://cr.yp.to/software/${P}.tar.gz
- http://csa-net.dk/djbware/ezmlm-0.53-ia64.patch"
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
HOMEPAGE="http://cr.yp.to/${PN}.html"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz
+ http://csa-net.dk/djbware/ezmlm-0.53-ia64.patch"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 sparc ppc alpha"
+IUSE=""
DEPEND="sys-apps/groff"
-RDEPEND="|| ( mail-mta/qmail
- mail-mta/qmail-mysql
- mail-mta/qmail-ldap )"
-S=${WORKDIR}/${P}
+RDEPEND="|| (
+ mail-mta/qmail
+ mail-mta/qmail-mysql
+ mail-mta/qmail-ldap )"
src_unpack() {
unpack ${A}
@@ -28,8 +29,8 @@ src_unpack() {
ht_fix_file Makefile *.do
echo "/usr/bin" > conf-bin
echo "/usr/share/man" > conf-man
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(gcc-getCC) ${LDFLAGS}" > conf-ld
}
src_compile() {
@@ -40,8 +41,9 @@ src_compile() {
src_install () {
dobin ezmlm-list ezmlm-make ezmlm-manage \
- ezmlm-reject ezmlm-return ezmlm-send \
- ezmlm-sub ezmlm-unsub ezmlm-warn ezmlm-weed
+ ezmlm-reject ezmlm-return ezmlm-send \
+ ezmlm-sub ezmlm-unsub ezmlm-warn ezmlm-weed \
+ || die
doman *.1 *.5
}