summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-16 17:17:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-16 17:17:10 +0000
commit42b5665d831dcc2e81e6cecd9d4a5208e33df9d1 (patch)
treee522f5858f7c5e468b282079d5b597b521449f71 /net-mail
parentNew ebuild. Initial import from kde overlay. (diff)
downloadgentoo-2-42b5665d831dcc2e81e6cecd9d4a5208e33df9d1.tar.gz
gentoo-2-42b5665d831dcc2e81e6cecd9d4a5208e33df9d1.tar.bz2
gentoo-2-42b5665d831dcc2e81e6cecd9d4a5208e33df9d1.zip
Remove USE="gnome" and always pass --disable-gnome to avoid pulling in deprecated version of gnome-panel.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/gnubiff/ChangeLog11
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.13-r3.ebuild44
2 files changed, 53 insertions, 2 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index 27476c937995..34f2fa815d11 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/gnubiff
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.37 2011/12/04 19:18:38 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.38 2012/01/16 17:17:10 ssuominen Exp $
+
+*gnubiff-2.2.13-r3 (16 Jan 2012)
+
+ 16 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +gnubiff-2.2.13-r3.ebuild:
+ Remove USE="gnome" and always pass --disable-gnome to avoid pulling in
+ deprecated version of gnome-panel.
04 Dec 2011; Tim Harder <radhermit@gentoo.org> -gnubiff-2.2.13-r1.ebuild:
Remove old.
diff --git a/net-mail/gnubiff/gnubiff-2.2.13-r3.ebuild b/net-mail/gnubiff/gnubiff-2.2.13-r3.ebuild
new file mode 100644
index 000000000000..adc2eee27d11
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.13-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.13-r3.ebuild,v 1.1 2012/01/16 17:17:10 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fam nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ password? ( dev-libs/openssl:0 )
+ fam? ( virtual/fam )
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-nls.patch \
+ "${FILESDIR}"/${P}-gold.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-gnome \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}