summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-03-22 10:41:58 +0000
committerEray Aslan <eras@gentoo.org>2013-03-22 10:41:58 +0000
commit228ea23cb7dbb0a469e85d0089802c209118ac35 (patch)
tree042b09f42331336dd36cc5d94acd0ea6e31473a4 /net-mail
parentRemove mask entry for mkxf86config, and old version of livecd-tools. Former i... (diff)
downloadgentoo-2-228ea23cb7dbb0a469e85d0089802c209118ac35.tar.gz
gentoo-2-228ea23cb7dbb0a469e85d0089802c209118ac35.tar.bz2
gentoo-2-228ea23cb7dbb0a469e85d0089802c209118ac35.zip
Version bump
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailutils/ChangeLog8
-rw-r--r--net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch11
-rw-r--r--net-mail/mailutils/mailutils-2.99.98.ebuild131
3 files changed, 149 insertions, 1 deletions
diff --git a/net-mail/mailutils/ChangeLog b/net-mail/mailutils/ChangeLog
index c3000ef470ee..ff0a2012c3b2 100644
--- a/net-mail/mailutils/ChangeLog
+++ b/net-mail/mailutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.64 2013/02/28 13:03:29 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/ChangeLog,v 1.65 2013/03/22 10:41:58 eras Exp $
+
+*mailutils-2.99.98 (22 Mar 2013)
+
+ 22 Mar 2013; Eray Aslan <eras@gentoo.org>
+ +files/mailutils-2.99.98-array_bounds.patch, +mailutils-2.99.98.ebuild:
+ Version bump
28 Feb 2013; Eray Aslan <eras@gentoo.org> mailutils-2.99.97.ebuild:
Use tc-getPKG_CONFIG instead of calling pkg-config directly
diff --git a/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch b/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch
new file mode 100644
index 000000000000..8ac418c7c037
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch
@@ -0,0 +1,11 @@
+--- libmu_auth/ldap.c 2012-03-25 14:02:22.000000000 +0300
++++ libmu_auth/ldap.c 2013-03-22 12:29:19.034880845 +0200
+@@ -534,7 +534,7 @@
+
+ env[0] = "user";
+ env[1] = key;
+- env[3] = NULL;
++ env[2] = NULL;
+
+ ws.ws_env = env;
+ if (mu_wordsplit (filter_pat, &ws,
diff --git a/net-mail/mailutils/mailutils-2.99.98.ebuild b/net-mail/mailutils/mailutils-2.99.98.ebuild
new file mode 100644
index 000000000000..5555a6079b1e
--- /dev/null
+++ b/net-mail/mailutils/mailutils-2.99.98.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-2.99.98.ebuild,v 1.1 2013/03/22 10:41:58 eras Exp $
+
+EAPI=5
+PYTHON_DEPEND="python? 2"
+
+inherit eutils flag-o-matic python toolchain-funcs
+
+DESCRIPTION="A useful collection of mail servers, clients, and filters."
+HOMEPAGE="http://www.gnu.org/software/mailutils/mailutils.html"
+#SRC_URI="mirror://gnu/mailutils/${P}.tar.xz"
+SRC_URI="mirror://gnu-alpha/mailutils/${P}.tar.xz"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="berkdb bidi +clients gdbm sasl guile ipv6 kerberos ldap mysql nls pam postgres
+python servers ssl static-libs +threads tcpd tokyocabinet"
+
+RDEPEND="!mail-client/nmh
+ !mail-filter/libsieve
+ !mail-client/mailx
+ !mail-client/nail
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-devel/libtool
+ virtual/mta
+ berkdb? ( sys-libs/db )
+ bidi? ( dev-libs/fribidi )
+ gdbm? ( sys-libs/gdbm )
+ guile? ( dev-scheme/guile )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ sasl? ( virtual/gsasl )
+ ssl? ( net-libs/gnutls )
+ tcpd? ( sys-apps/tcp-wrappers )
+ tokyocabinet? ( dev-db/tokyocabinet )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Disable bytecompilation of Python modules.
+ echo "#!/bin/sh" > build-aux/py-compile
+ epatch "${FILESDIR}/${P}-array_bounds.patch"
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # maildir is the Gentoo default
+ # but fails tests. So set it in config file instead.
+ #econf MU_DEFAULT_SCHEME=maildir \
+ econf CURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+ $(use_with berkdb berkeley-db) \
+ $(use_with bidi fribidi) \
+ $(use_enable ipv6) \
+ $(use_with gdbm) \
+ $(use_with sasl gsasl) \
+ $(use_with guile) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with postgres) \
+ $(use_enable python) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread) \
+ $(use_with tokyocabinet) \
+ $(use_enable servers build-servers) \
+ $(use_enable clients build-clients) \
+ --with-mail-spool=/var/spool/mail \
+ --with-readline \
+ --enable-sendmail \
+ --disable-debug \
+ --disable-rpath
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ doins "${FILESDIR}/mailutils.rc"
+ keepdir /etc/mailutils.d/
+ insinto /etc/mailutils.d
+ doins "${FILESDIR}/mail"
+
+ if use python; then
+ python_clean_installation_image
+ rm -f "${ED}$(python_get_sitedir)/mailutils/c_api.a"
+ fi
+
+ if use servers; then
+ newinitd "${FILESDIR}"/imap4d.initd imap4d
+ newinitd "${FILESDIR}"/pop3d.initd pop3d
+ newinitd "${FILESDIR}"/comsatd.initd comsatd
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+
+ # compatibility link
+ use clients && dosym /usr/bin/mail /bin/mail
+
+ use static-libs || find "${D}" -name "*.la" -delete
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize mailutils
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup mailutils
+ fi
+}