summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-10-26 19:54:07 +0000
committerTom Martin <slarti@gentoo.org>2004-10-26 19:54:07 +0000
commit47b02ee63eb01a0cf11ae6fd52e9efc1dff948a3 (patch)
tree8d50f142cb0c62635f686181ab70bd44a8cb94b7 /net-mail/qmail-autoresponder
parentAdding ~amd64 w/ quick fix from #68605. (Manifest recommit) (diff)
downloadgentoo-2-47b02ee63eb01a0cf11ae6fd52e9efc1dff948a3.tar.gz
gentoo-2-47b02ee63eb01a0cf11ae6fd52e9efc1dff948a3.tar.bz2
gentoo-2-47b02ee63eb01a0cf11ae6fd52e9efc1dff948a3.zip
Added ~amd64 and fixed #69004
Diffstat (limited to 'net-mail/qmail-autoresponder')
-rw-r--r--net-mail/qmail-autoresponder/ChangeLog7
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild8
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild10
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild8
4 files changed, 20 insertions, 13 deletions
diff --git a/net-mail/qmail-autoresponder/ChangeLog b/net-mail/qmail-autoresponder/ChangeLog
index 29537a1db87a..87c8503be4e4 100644
--- a/net-mail/qmail-autoresponder/ChangeLog
+++ b/net-mail/qmail-autoresponder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/qmail-autoresponder
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/ChangeLog,v 1.15 2004/07/01 22:34:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/ChangeLog,v 1.16 2004/10/26 19:54:07 slarti Exp $
+
+ 26 Oct 2004; Tom Martin <slarti@gentoo.org>
+ qmail-autoresponder-0.95.ebuild, qmail-autoresponder-0.96.1-r1.ebuild,
+ qmail-autoresponder-0.96.1.ebuild:
+ Marked ~amd64. Updated to use toolchain-funcs, see bug 69004.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
qmail-autoresponder-0.95.ebuild, qmail-autoresponder-0.96.1-r1.ebuild,
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
index 2f31cdfd8bf8..e5818d893faf 100644
--- a/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild,v 1.15 2004/07/15 01:57:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild,v 1.16 2004/10/26 19:54:07 slarti Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Rate-limited autoresponder for qmail."
SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
@@ -16,8 +18,8 @@ RDEPEND=">=mail-mta/qmail-1.03-r7"
src_compile() {
cd ${S}
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getLD) ${LDFLAGS}" > conf-ld
emake || die
}
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
index a041c5e98ed4..4f1e50b4d7f4 100644
--- a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild,v 1.10 2004/07/15 01:57:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1-r1.ebuild,v 1.11 2004/10/26 19:54:07 slarti Exp $
-inherit fixheadtails eutils
+inherit fixheadtails eutils toolchain-funcs
DESCRIPTION="Rate-limited autoresponder for qmail."
SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
@@ -10,7 +10,7 @@ HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc ppc alpha ~mips ~hppa"
+KEYWORDS="x86 sparc ppc alpha ~mips ~hppa ~amd64"
IUSE="mysql"
DEPEND="virtual/libc
@@ -34,8 +34,8 @@ src_compile() {
cd ${S}
echo "/usr/lib/bglibs/include" > conf-bgincs
echo "/usr/lib/bglibs/lib" > conf-bglibs
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
# fails on parallel builds!
make qmail-autoresponder || die "Failed to make qmail-autoresponder"
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
index 661e8bb155d8..b50112e54d82 100644
--- a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild,v 1.9 2004/07/15 01:57:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild,v 1.10 2004/10/26 19:54:07 slarti Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Rate-limited autoresponder for qmail."
SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
@@ -29,8 +29,8 @@ src_compile() {
cd ${S}
echo "/usr/lib/bglibs/include" > conf-bgincs
echo "/usr/lib/bglibs/lib" > conf-bglibs
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getLD) ${LDFLAGS}" > conf-ld
make || die
}