summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-06 19:32:56 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-06 19:32:56 +0000
commite954f2ad2f4fa68a09e39060aaa6628a4a0bf68f (patch)
treec774b57adf89d707b478a541cdfb27b0ce160ba3 /net-mail/fetchmail
parentQA: Removed unused versions. (diff)
downloadgentoo-2-e954f2ad2f4fa68a09e39060aaa6628a4a0bf68f.tar.gz
gentoo-2-e954f2ad2f4fa68a09e39060aaa6628a4a0bf68f.tar.bz2
gentoo-2-e954f2ad2f4fa68a09e39060aaa6628a4a0bf68f.zip
Version bump.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.6.ebuild83
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.3.63
3 files changed, 92 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index cb3dc1cac51e..cb42b6df7953 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.114 2007/01/05 16:56:32 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.115 2007/01/06 19:32:56 ticho Exp $
+
+*fetchmail-6.3.6 (06 Jan 2007)
+
+ 06 Jan 2007; Andrej Kacian <ticho@gentoo.org> +fetchmail-6.3.6.ebuild:
+ Version bump.
05 Jan 2007; Andrej Kacian <ticho@gentoo.org>
-files/fetchmail-6.2.5-mit-krb5-1.4.patch:
diff --git a/net-mail/fetchmail/fetchmail-6.3.6.ebuild b/net-mail/fetchmail/fetchmail-6.3.6.ebuild
new file mode 100644
index 000000000000..cfe81a3bff4e
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.6.ebuild,v 1.1 2007/01/06 19:32:56 ticho Exp $
+
+inherit eutils
+
+FCONF_P="fetchmailconf-1.43.2"
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download2.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~x86-fbsd"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+DEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( sys-devel/gettext )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd \${S} failed"
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch ${FILESDIR}/${PN}-6.2.5-broken-headers.patch || die
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING
+
+ newinitd ${FILESDIR}/fetchmail fetchmail
+ newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.6 b/net-mail/fetchmail/files/digest-fetchmail-6.3.6
new file mode 100644
index 000000000000..78542dd518c2
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.3.6
@@ -0,0 +1,3 @@
+MD5 4fab7ca100ca36e41a2e8dbf5b32a3cf fetchmail-6.3.6.tar.bz2 1307730
+RMD160 455c1413cc5090f834e82be4876b572d4bef35cc fetchmail-6.3.6.tar.bz2 1307730
+SHA256 3c81e7776617b78f18d9cd8b5e5f62944e70f1d7bd47a840fd8d44bcded784ff fetchmail-6.3.6.tar.bz2 1307730