summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-04 11:06:12 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-04 11:06:12 +0000
commitd7f500efb1c1335cd22bd1a8ece352b9031264bf (patch)
tree1dcfc065b1e4931e14fd44a08d13391928271373 /net-libs
parentUpdate multilib stable mask (diff)
downloadgentoo-2-d7f500efb1c1335cd22bd1a8ece352b9031264bf.tar.gz
gentoo-2-d7f500efb1c1335cd22bd1a8ece352b9031264bf.tar.bz2
gentoo-2-d7f500efb1c1335cd22bd1a8ece352b9031264bf.zip
Drop farsight support (#514464)
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt/ChangeLog7
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.3-r2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index b43019278720..81f80d6fefcd 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.26 2014/04/13 16:06:40 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.27 2014/07/04 11:06:12 pacho Exp $
+
+*telepathy-qt-0.9.3-r2 (04 Jul 2014)
+
+ 04 Jul 2014; Pacho Ramos <pacho@gentoo.org> +telepathy-qt-0.9.3-r2.ebuild:
+ Drop farsight support (#514464)
13 Apr 2014; Johannes Huber <johu@gentoo.org>
-files/telepathy-qt-0.8.0-automagicness.patch,
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.3-r2.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..f464849a600e
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.3-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.3-r2.ebuild,v 1.1 2014/07/04 11:06:12 pacho Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit base python-any-r1 cmake-utils virtualx
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug farstream test"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+ !net-libs/telepathy-qt4
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? (
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-python/dbus-python
+ dev-qt/qttest:4
+ )
+"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-tp-glib-0.18-tests.patch"
+ "${FILESDIR}/${P}-avatar-duplication.patch"
+ "${FILESDIR}/${P}-cmake-2.8.12.patch"
+)
+
+# test hangs, needs further investigation
+RESTRICT="test"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable farstream)
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_enable test TESTS)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ Xemake test || die "tests failed"
+ popd > /dev/null
+}