summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-12 17:23:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-12 17:23:56 +0000
commitcbdb4cffddcb4cf09d4d0113865740f78dac72f1 (patch)
treee59cfcc5c55925e059f027658c0fe359af0cba66 /net-libs
parentStable for ppc, wrt bug #480126 (diff)
downloadgentoo-2-cbdb4cffddcb4cf09d4d0113865740f78dac72f1.tar.gz
gentoo-2-cbdb4cffddcb4cf09d4d0113865740f78dac72f1.tar.bz2
gentoo-2-cbdb4cffddcb4cf09d4d0113865740f78dac72f1.zip
Version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnatpmp/ChangeLog5
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20130911.patch53
-rw-r--r--net-libs/libnatpmp/libnatpmp-20130911.ebuild29
3 files changed, 87 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/ChangeLog b/net-libs/libnatpmp/ChangeLog
index df3fd6ad6998..c942566c41ce 100644
--- a/net-libs/libnatpmp/ChangeLog
+++ b/net-libs/libnatpmp/ChangeLog
@@ -1,4 +1,9 @@
+*libnatpmp-20130911 (12 Sep 2013)
+
+ 12 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/respect-FLAGS-20130911.patch, +libnatpmp-20130911.ebuild:
+ Version bump
16 Dec 2012; Raúl Porcel <armin76@gentoo.org> libnatpmp-20110808-r1.ebuild,
libnatpmp-20120821.ebuild:
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch b/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
new file mode 100644
index 000000000000..df36e2d4a4a0
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
@@ -0,0 +1,53 @@
+diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
+--- libnatpmp-20130911.orig/Makefile 2013-09-10 16:15:06.000000000 -0400
++++ libnatpmp-20130911/Makefile 2013-09-12 13:20:29.191447842 -0400
+@@ -5,7 +5,7 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+ VERSION = $(shell cat VERSION)
+
+@@ -22,6 +22,7 @@
+ # APIVERSION is used in soname
+ APIVERSION = 1
+ #LDFLAGS = -Wl,--no-undefined
++GENTOO_CFLAGS := $(CFLAGS)
+ CFLAGS = -Os
+ #CFLAGS = -g -O0
+ CFLAGS += -fPIC
+@@ -52,6 +53,8 @@
+ endif
+ endif
+
++CFLAGS := $(CFLAGS) $(GENTOO_CFLAGS)
++
+ HEADERS = natpmp.h
+
+ EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
+@@ -144,19 +147,19 @@
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+
diff --git a/net-libs/libnatpmp/libnatpmp-20130911.ebuild b/net-libs/libnatpmp/libnatpmp-20130911.ebuild
new file mode 100644
index 000000000000..0d5e89356db0
--- /dev/null
+++ b/net-libs/libnatpmp/libnatpmp-20130911.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnatpmp/libnatpmp-20130911.ebuild,v 1.1 2013/09/12 17:23:56 blueness Exp $
+
+EAPI="5"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="An alternative protocol to UPnP IGD specification"
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+SRC_URI="http://miniupnp.free.fr/files/download.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/respect-FLAGS-${PV}.patch
+ epatch "${FILESDIR}"/respect-libdir-20120821.patch
+ use static-libs || epatch "${FILESDIR}"/remove-static-lib-20120821.patch
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}" GENTOO_LIBDIR="$(get_libdir)" install
+
+ dodoc Changelog.txt README
+ doman natpmpc.1
+}