summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-29 00:06:04 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-29 00:06:04 +0000
commitc978778ce06a03caf1d5202b8ac9ee27688e0a6d (patch)
tree066e0d0af8f6a4f8fce11eabdca0d13b5339f796 /net-libs
parentAdd patch to fix compilation with gcc-4.3 and gcc-4.4 by Gene Seto <geneseto ... (diff)
downloadgentoo-2-c978778ce06a03caf1d5202b8ac9ee27688e0a6d.tar.gz
gentoo-2-c978778ce06a03caf1d5202b8ac9ee27688e0a6d.tar.bz2
gentoo-2-c978778ce06a03caf1d5202b8ac9ee27688e0a6d.zip
Restrict test on 0.13-r1, which breaks due to CVE patch. Remove old ebuild.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog7
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild3
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild55
3 files changed, 8 insertions, 57 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index e7eb5a805439..2f2943e89ed6 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.60 2009/06/28 14:50:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.61 2009/06/29 00:06:04 yngwin Exp $
+
+ 29 Jun 2009; Ben de Groot <yngwin@gentoo.org>
+ rb_libtorrent-0.13-r1.ebuild, -rb_libtorrent-0.14.4.ebuild:
+ Restrict test on 0.13-r1, which breaks due to CVE patch. Remove old
+ ebuild.
*rb_libtorrent-0.14.4-r1 (28 Jun 2009)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
index 929c0ba3c276..5b0e78265026 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild,v 1.1 2009/06/28 00:02:56 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13-r1.ebuild,v 1.2 2009/06/29 00:06:04 yngwin Exp $
EAPI="2"
inherit eutils flag-o-matic
+RESTRICT="test" # tests break due to the CVE patch :(
MY_P=${P/rb_/}
S=${WORKDIR}/${MY_P}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild
deleted file mode 100644
index 80f01f249b60..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild,v 1.1 2009/06/06 16:30:06 armin76 Exp $
-
-inherit eutils autotools
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-
-IUSE="debug examples python test"
-
-DEPEND="
- >=dev-libs/boost-1.34
- || ( >=dev-libs/boost-1.35 dev-cpp/asio )
- sys-libs/zlib
- !net-libs/libtorrent"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- #use multi-threading versions of boost libs
- local BOOST_LIBS="
- --with-boost-system=boost_system-mt \
- --with-boost-asio=boost_system-mt \
- --with-boost-filesystem=boost_filesystem-mt \
- --with-boost-thread=boost_thread-mt \
- --with-boost-regex=boost_regex-mt \
- --with-boost-python=boost_python-mt \
- --with-boost-program_options=boost_program_options-mt"
-
- #TODO: We might want to add 'use debug -> --with-logging=verbose
- econf \
- $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- --with-zlib=system \
- --with-asio=system \
- ${BOOST_LIBS} \
- LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog AUTHORS NEWS README
-}