summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-02-20 22:58:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-02-20 22:58:06 +0000
commitc08e75778ccc4ca76fb1fb2c502fa676018bb411 (patch)
tree0b72a3dad0e97b58ecdf4ace2ef65e49f2d20be3 /net-libs
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-c08e75778ccc4ca76fb1fb2c502fa676018bb411.tar.gz
gentoo-2-c08e75778ccc4ca76fb1fb2c502fa676018bb411.tar.bz2
gentoo-2-c08e75778ccc4ca76fb1fb2c502fa676018bb411.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog9
-rw-r--r--net-libs/libsoup/libsoup-2.40.3.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index ecc73872f98c..eace51eb1408 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libsoup
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.296 2012/12/17 05:14:55 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.297 2013/02/20 22:58:06 eva Exp $
+
+*libsoup-2.40.3 (20 Feb 2013)
+
+ 20 Feb 2013; Gilles Dartiguelongue <eva@gentoo.org> +libsoup-2.40.3.ebuild:
+ Version bump.
*libsoup-2.40.2 (17 Dec 2012)
diff --git a/net-libs/libsoup/libsoup-2.40.3.ebuild b/net-libs/libsoup/libsoup-2.40.3.ebuild
new file mode 100644
index 000000000000..fcfb658d68f7
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.40.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.40.3.ebuild,v 1.1 2013/02/20 22:58:06 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://live.gnome.org/LibSoup"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug +introspection samba ssl test"
+
+RDEPEND=">=dev-libs/glib-2.33.1:2
+ >=dev-libs/libxml2-2:2
+ >=net-libs/glib-networking-2.30.0[ssl?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ samba? ( net-fs/samba )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ virtual/pkgconfig"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests (bug #226271)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ gnome2_src_configure \
+ --disable-static \
+ --disable-tls-check \
+ --without-gnome \
+ --without-apache-httpd \
+ $(use_enable introspection) \
+ $(use_with samba ntlm-auth "${EPREFIX}"/usr/bin/ntlm_auth)
+}