summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-31 21:33:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-31 21:33:45 +0000
commitae5fe4d982b85ba4dff36c1355bd13a6c4ee6254 (patch)
tree1500247213cf21314730e27d4091ba2cb43519e0 /net-libs
parentUpdate copyright years. (diff)
downloadgentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.tar.gz
gentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.tar.bz2
gentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.zip
Fix glibc 2.8 build, thanks to Gene Seto for the required patch. Version bump as well
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gloox/ChangeLog12
-rw-r--r--net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch12
-rw-r--r--net-libs/gloox/gloox-0.8.4.ebuild34
-rw-r--r--net-libs/gloox/gloox-0.9.9.3.ebuild34
-rw-r--r--net-libs/gloox/gloox-0.9.9.4.ebuild43
-rw-r--r--net-libs/gloox/gloox-0.9.9.5.ebuild15
-rw-r--r--net-libs/gloox/gloox-1.0_beta4.ebuild (renamed from net-libs/gloox/gloox-1.0_beta2.ebuild)14
7 files changed, 40 insertions, 124 deletions
diff --git a/net-libs/gloox/ChangeLog b/net-libs/gloox/ChangeLog
index 80ebf41822e7..5f82071d3747 100644
--- a/net-libs/gloox/ChangeLog
+++ b/net-libs/gloox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/gloox
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.9 2008/04/21 19:40:04 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.10 2009/01/31 21:33:45 jokey Exp $
+
+*gloox-1.0_beta4 (31 Jan 2009)
+
+ 31 Jan 2009; <jokey@gentoo.org> +files/gloox-0.9.9.5-gcc43.patch,
+ -gloox-0.8.4.ebuild, -gloox-0.9.9.3.ebuild, -gloox-0.9.9.4.ebuild,
+ gloox-0.9.9.5.ebuild, -gloox-1.0_beta2.ebuild, +gloox-1.0_beta4.ebuild:
+ Fix glibc 2.8 build, thanks to Gene Seto for the required patch. Version
+ bump as well
*gloox-1.0_beta2 (21 Apr 2008)
diff --git a/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch b/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch
new file mode 100644
index 000000000000..0fa4fd465121
--- /dev/null
+++ b/net-libs/gloox/files/gloox-0.9.9.5-gcc43.patch
@@ -0,0 +1,12 @@
+--- gloox-0.9.9.5b/src/tlsopenssl.cpp 2009-01-21 22:43:06.000000000 -0400
++++ gloox-0.9.9.5/src/tlsopenssl.cpp 2009-01-22 00:42:53.000000000 -0400
+@@ -223,7 +223,8 @@
+ m_certInfo.date_to = openSSLTime2UnixTime( (char*)(peer->cert_info->validity->notAfter->data) );
+ std::string p;
+ p.assign( peer_CN );
+- std::transform( p.begin(), p.end(), p.begin(), std::tolower );
++ /* http://lists.debian.org/debian-gcc/2002/04/msg00092.html */
++ std::transform( p.begin(), p.end(), p.begin(), (int(*)(int))std::tolower );
+ if( p != m_server )
+ m_certInfo.status |= CertWrongPeer;
+
diff --git a/net-libs/gloox/gloox-0.8.4.ebuild b/net-libs/gloox/gloox-0.8.4.ebuild
deleted file mode 100644
index f2a2141fa7f3..000000000000
--- a/net-libs/gloox/gloox-0.8.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.8.4.ebuild,v 1.1 2007/10/22 21:43:59 jokey Exp $
-
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug gnutls idn ssl zlib"
-
-DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
- gnutls? ( >=net-libs/gnutls-1.2.0 )
- ssl? ( >=dev-libs/openssl-0.9.7 )
- zlib? ( sys-libs/zlib )
- dev-libs/iksemel"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- econf \
- $(use_enable debug debug) \
- $(use_with idn libidn) \
- $(use_with gnutls gnutls) \
- $(use_with ssl openssl) \
- $(use_with zlib zlib) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-libs/gloox/gloox-0.9.9.3.ebuild b/net-libs/gloox/gloox-0.9.9.3.ebuild
deleted file mode 100644
index ebd1e280975c..000000000000
--- a/net-libs/gloox/gloox-0.9.9.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.3.ebuild,v 1.1 2008/03/04 20:13:32 jokey Exp $
-
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug gnutls idn ssl zlib"
-
-DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
- gnutls? ( >=net-libs/gnutls-1.2.0 )
- ssl? ( >=dev-libs/openssl-0.9.8 )
- zlib? ( >=sys-libs/zlib-1.2.3 )"
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
- econf \
- $(use_enable debug debug) \
- $(use_with idn libidn) \
- $(use_with gnutls gnutls) \
- $(use_with ssl openssl) \
- $(use_with zlib zlib) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-libs/gloox/gloox-0.9.9.4.ebuild b/net-libs/gloox/gloox-0.9.9.4.ebuild
deleted file mode 100644
index 7dfddc0d035a..000000000000
--- a/net-libs/gloox/gloox-0.9.9.4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.4.ebuild,v 1.1 2008/03/18 21:15:42 jokey Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug gnutls idn ssl zlib"
-
-DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
- gnutls? ( >=net-libs/gnutls-1.2.0 )
- ssl? ( >=dev-libs/openssl-0.9.8 )
- zlib? ( >=sys-libs/zlib-1.2.3 )"
-
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-res_query-check.patch
- eautoreconf
-}
-
-src_compile() {
- econf \
- $(use_enable debug debug) \
- $(use_with idn libidn) \
- $(use_with gnutls gnutls) \
- $(use_with ssl openssl) \
- $(use_with zlib zlib) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-libs/gloox/gloox-0.9.9.5.ebuild b/net-libs/gloox/gloox-0.9.9.5.ebuild
index bdef351f11fc..cf791ab6b2bd 100644
--- a/net-libs/gloox/gloox-0.9.9.5.ebuild
+++ b/net-libs/gloox/gloox-0.9.9.5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.5.ebuild,v 1.1 2008/04/21 19:05:36 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.5.ebuild,v 1.2 2009/01/31 21:33:45 jokey Exp $
-inherit autotools
+EAPI=2
+
+inherit autotools eutils
DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
HOMEPAGE="http://camaya.net/gloox"
@@ -20,7 +22,11 @@ DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
RDEPEND="${DEPEND}"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_configure() {
econf \
$(use_enable debug debug) \
$(use_with idn libidn) \
@@ -28,7 +34,6 @@ src_compile() {
$(use_with ssl openssl) \
$(use_with zlib zlib) \
|| die "econf failed"
- emake || die "emake failed"
}
src_install() {
diff --git a/net-libs/gloox/gloox-1.0_beta2.ebuild b/net-libs/gloox/gloox-1.0_beta4.ebuild
index 95dd1fb0cad6..54b6ac9a2e7e 100644
--- a/net-libs/gloox/gloox-1.0_beta2.ebuild
+++ b/net-libs/gloox/gloox-1.0_beta4.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0_beta2.ebuild,v 1.1 2008/04/21 19:40:04 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0_beta4.ebuild,v 1.1 2009/01/31 21:33:45 jokey Exp $
+
+EAPI=2
inherit autotools
+MY_P=${P/_/-}
DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
HOMEPAGE="http://camaya.net/gloox"
-SRC_URI="http://camaya.net/download/${PN}-1.0-beta2.tar.bz2"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -20,9 +23,9 @@ DEPEND="idn? ( net-dns/libidn )
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}-1.0-beta2
+S=${WORKDIR}/${MY_P}
-src_compile() {
+src_configure() {
econf \
$(use_enable debug debug) \
$(use_with idn libidn) \
@@ -30,7 +33,6 @@ src_compile() {
$(use_with ssl openssl) \
$(use_with zlib zlib) \
|| die "econf failed"
- emake || die "emake failed"
}
src_install() {