summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-04-14 08:57:55 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-04-14 08:57:55 +0000
commit53248f46cb61ae8ee6469ba236637b086ac411ed (patch)
tree168338997a3b31661c877c2215bc85863d2da047 /net-libs/opal
parentVersion bump, fix ldap depend (diff)
downloadgentoo-2-53248f46cb61ae8ee6469ba236637b086ac411ed.tar.gz
gentoo-2-53248f46cb61ae8ee6469ba236637b086ac411ed.tar.bz2
gentoo-2-53248f46cb61ae8ee6469ba236637b086ac411ed.zip
version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-libs/opal')
-rw-r--r--net-libs/opal/ChangeLog7
-rw-r--r--net-libs/opal/files/digest-opal-2.2.83
-rw-r--r--net-libs/opal/opal-2.2.8.ebuild104
3 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index 3c7d4424fc05..4e7fe2fbee5c 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.31 2007/04/14 08:14:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.32 2007/04/14 08:57:55 genstef Exp $
+
+*opal-2.2.8 (14 Apr 2007)
+
+ 14 Apr 2007; Stefan Schweizer <genstef@gentoo.org> +opal-2.2.8.ebuild:
+ version bump
14 Apr 2007; Stefan Schweizer <genstef@gentoo.org> -opal-2.2.1.ebuild,
-opal-2.2.2.ebuild, -opal-2.2.3.ebuild, -opal-2.2.5.ebuild:
diff --git a/net-libs/opal/files/digest-opal-2.2.8 b/net-libs/opal/files/digest-opal-2.2.8
new file mode 100644
index 000000000000..0f66ab399ffa
--- /dev/null
+++ b/net-libs/opal/files/digest-opal-2.2.8
@@ -0,0 +1,3 @@
+MD5 700b0c3a7606afc0dc6c9d3c12fcb23b opal-2.2.8.tar.gz 4162369
+RMD160 5974537aced1c2b531ebeb0efa8a71fff7e695e8 opal-2.2.8.tar.gz 4162369
+SHA256 890132438781c980ab5297795f049d57b13ae78b64c238c936c320adf2bd35fa opal-2.2.8.tar.gz 4162369
diff --git a/net-libs/opal/opal-2.2.8.ebuild b/net-libs/opal/opal-2.2.8.ebuild
new file mode 100644
index 000000000000..804057f917f5
--- /dev/null
+++ b/net-libs/opal/opal-2.2.8.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.8.ebuild,v 1.1 2007/04/14 08:57:55 genstef Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="OPAL library, used by Ekiga"
+HOMEPAGE="http://www.ekiga.org"
+SRC_URI="http://www.ekiga.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+IUSE="novideo noaudio debug"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="~dev-libs/pwlib-1.10.$[${PV##*.}-1]
+ >=media-video/ffmpeg-0.4.7"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch ${FILESDIR}/${PN}-2.1.1-notrace.diff
+}
+
+src_compile() {
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ # doesn't work with osptoolkit-3.3.1
+ # iax2 support is missing in the tarball, disable it too
+ myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf \
+ PWLIBDIR=/usr/share/pwlib \
+ OPALDIR=${S} \
+ ${myconf} || die "configure failed"
+
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
+ local makeopts libdir libname
+
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPAL_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPAL_SUFFIX="r"
+ fi
+
+ # use ptlib-config to get the right values here (for hppa, amd64 ...)
+ OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPAL_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPAL_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR=${D} \
+ ${makeopts} install || die "install failed"
+
+ libdir=$(get_libdir)
+ libname="libopal_${OPAL_ARCH}.so.${PV}"
+
+ # compat symlinks
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
+ done
+ dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # install version.h into $OPALDIR
+ insinto /usr/share/opal
+ doins version.h
+}