summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-02-21 23:04:28 +0000
committerRémi Cardona <remi@gentoo.org>2007-02-21 23:04:28 +0000
commit1e96a6937da8152213d836bde29e7b91196d8fe7 (patch)
tree1864689a904b78d20816147396ff6ce44f3fc4dc /net-libs/opal
parentTransition to Manifest2. (diff)
downloadgentoo-2-1e96a6937da8152213d836bde29e7b91196d8fe7.tar.gz
gentoo-2-1e96a6937da8152213d836bde29e7b91196d8fe7.tar.bz2
gentoo-2-1e96a6937da8152213d836bde29e7b91196d8fe7.zip
bumping opal to 2.2.5
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-libs/opal')
-rw-r--r--net-libs/opal/ChangeLog7
-rw-r--r--net-libs/opal/files/digest-opal-2.2.53
-rw-r--r--net-libs/opal/opal-2.2.5.ebuild104
3 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index bfdb31ff9506..7506d413160b 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.17 2007/01/19 01:21:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.18 2007/02/21 23:04:28 remi Exp $
+
+*opal-2.2.5 (21 Feb 2007)
+
+ 21 Feb 2007; Remi Cardona <remi@gentoo.org> +opal-2.2.5.ebuild:
+ bumping opal to 2.2.5
19 Jan 2007; Jeroen Roovers <jer@gentoo.org> opal-2.2.3.ebuild:
Stable for HPPA (bug #147751).
diff --git a/net-libs/opal/files/digest-opal-2.2.5 b/net-libs/opal/files/digest-opal-2.2.5
new file mode 100644
index 000000000000..13c7a79d6746
--- /dev/null
+++ b/net-libs/opal/files/digest-opal-2.2.5
@@ -0,0 +1,3 @@
+MD5 d85407085c391fecc89451fd5c132645 opal-2.2.5.tar.gz 4158355
+RMD160 65930a5f951c316b1a9d80bab3efb40c092dd56a opal-2.2.5.tar.gz 4158355
+SHA256 4eae45d38c64337b645ffb2e487c48fa118c8746f189f0efb95b862a8d0d6075 opal-2.2.5.tar.gz 4158355
diff --git a/net-libs/opal/opal-2.2.5.ebuild b/net-libs/opal/opal-2.2.5.ebuild
new file mode 100644
index 000000000000..75f18df5d131
--- /dev/null
+++ b/net-libs/opal/opal-2.2.5.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.5.ebuild,v 1.1 2007/02/21 23:04:28 remi Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="OPAL library, used by Ekiga"
+HOMEPAGE="http://www.ekiga.org"
+SRC_URI="http://www.ekiga.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+IUSE="novideo noaudio debug"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/pwlib-1.10.4
+ >=media-video/ffmpeg-0.4.7"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch ${FILESDIR}/${PN}-2.1.1-notrace.diff
+}
+
+src_compile() {
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ # doesn't work with osptoolkit-3.3.1
+ # iax2 support is missing in the tarball, disable it too
+ myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf \
+ PWLIBDIR=/usr/share/pwlib \
+ OPALDIR=${S} \
+ ${myconf} || die "configure failed"
+
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
+ local makeopts libdir libname
+
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPAL_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPAL_SUFFIX="r"
+ fi
+
+ # use ptlib-config to get the right values here (for hppa, amd64 ...)
+ OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPAL_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPAL_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR=${D} \
+ ${makeopts} install || die "install failed"
+
+ libdir=$(get_libdir)
+ libname="libopal_${OPAL_ARCH}.so.${PV}"
+
+ # compat symlinks
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
+ done
+ dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # install version.h into $OPALDIR
+ insinto /usr/share/opal
+ doins version.h
+}