summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-11-08 12:58:17 +0000
committerCédric Krier <cedk@gentoo.org>2008-11-08 12:58:17 +0000
commitb218d365a9d36b894fb13b5bfcab03660c42f28e (patch)
treeaed1a21774493bdcd0c87993f7ce9368f5ceaf50 /net-libs/libpcap
parentStable on ppc wrt bug 245710 (diff)
downloadgentoo-2-b218d365a9d36b894fb13b5bfcab03660c42f28e.tar.gz
gentoo-2-b218d365a9d36b894fb13b5bfcab03660c42f28e.tar.bz2
gentoo-2-b218d365a9d36b894fb13b5bfcab03660c42f28e.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/ChangeLog9
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-bindir.patch11
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-whitespace.patch22
-rw-r--r--net-libs/libpcap/libpcap-1.0.0.ebuild59
4 files changed, 100 insertions, 1 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index 31f4f469ecdb..2cd7dd39da1a 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.112 2008/10/28 11:11:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.113 2008/11/08 12:58:17 cedk Exp $
+
+*libpcap-1.0.0 (08 Nov 2008)
+
+ 08 Nov 2008; Cédric Krier <cedk@gentoo.org>
+ +files/libpcap-1.0.0-bindir.patch, +files/libpcap-1.0.0-whitespace.patch,
+ +libpcap-1.0.0.ebuild:
+ Version bump
28 Oct 2008; Raúl Porcel <armin76@gentoo.org> libpcap-0.9.8-r2.ebuild:
alpha/ia64 stable #244234
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-bindir.patch b/net-libs/libpcap/files/libpcap-1.0.0-bindir.patch
new file mode 100644
index 000000000000..dc7ce1529b41
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-bindir.patch
@@ -0,0 +1,11 @@
+--- libpcap-1.0.0~/Makefile.in 2008-11-08 13:26:54.000000000 +0100
++++ libpcap-1.0.0/Makefile.in 2008-11-08 13:41:06.000000000 +0100
+@@ -445,6 +445,8 @@
+ $(DESTDIR)$(includedir)/pcap-bpf.h
+ $(INSTALL_DATA) $(srcdir)/pcap-namedb.h \
+ $(DESTDIR)$(includedir)/pcap-namedb.h
++ [ -d $(DESTDIR)$(bindir)] || \
++ (mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
+ $(INSTALL_PROGRAM) pcap-config $(DESTDIR)$(bindir)/pcap-config
+ for i in $(MAN1); do \
+ $(INSTALL_DATA) $(srcdir)/$$i \
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-whitespace.patch b/net-libs/libpcap/files/libpcap-1.0.0-whitespace.patch
new file mode 100644
index 000000000000..cd9d12485ab2
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-whitespace.patch
@@ -0,0 +1,22 @@
+diff -ru libpcap-1.0.0~/pcap/pcap.h libpcap-1.0.0/pcap/pcap.h
+--- libpcap-1.0.0~/pcap/pcap.h 2008-11-08 13:26:54.000000000 +0100
++++ libpcap-1.0.0/pcap/pcap.h 2008-11-08 13:27:06.000000000 +0100
+@@ -38,13 +38,13 @@
+ #define lib_pcap_pcap_h
+
+ #if defined(WIN32)
+- #include <pcap-stdinc.h>
++#include <pcap-stdinc.h>
+ #elif defined(MSDOS)
+- #include <sys/types.h>
+- #include <sys/socket.h> /* u_int, u_char etc. */
++#include <sys/types.h>
++#include <sys/socket.h> /* u_int, u_char etc. */
+ #else /* UN*X */
+- #include <sys/types.h>
+- #include <sys/time.h>
++#include <sys/types.h>
++#include <sys/time.h>
+ #endif /* WIN32/MSDOS/UN*X */
+
+ #ifndef PCAP_DONT_INCLUDE_PCAP_BPF_H
diff --git a/net-libs/libpcap/libpcap-1.0.0.ebuild b/net-libs/libpcap/libpcap-1.0.0.ebuild
new file mode 100644
index 000000000000..cb75473c4587
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.0.0.ebuild,v 1.1 2008/11/08 12:58:17 cedk Exp $
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="!virtual/libpcap"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+PROVIDE="virtual/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-whitespace.patch
+ epatch "${FILESDIR}"/${PN}-0.8.1-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-cross-linux.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-largefile.patch
+ epatch "${FILESDIR}"/${P}-bindir.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable ipv6)
+ emake || die "compile problem"
+
+ # no provision for this in the Makefile, so...
+ $(tc-getCC) ${LDFLAGS} -Wl,-soname,libpcap.so.0 -shared -fPIC -o libpcap.so.${PV:0:3} *.o \
+ || die "couldn't make a shared lib"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h || die "failed to install pcap-int.h"
+ fi
+
+ insopts -m 755
+ insinto /usr/$(get_libdir)
+ doins libpcap.so.${PV:0:3}
+ dosym libpcap.so.${PV:0:3} /usr/$(get_libdir)/libpcap.so.0
+ dosym libpcap.so.${PV:0:3} /usr/$(get_libdir)/libpcap.so
+
+ # We are not installing README.{Win32,aix,hpux,tru64} (bug 183057)
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel,.sita}
+}