summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 14:28:58 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 14:28:58 +0000
commiteb73937a5ce1fa6fd40772ad559a6a3e157dfea5 (patch)
tree6a094fa5a0046470b6c62d57a57b320755a841a5 /net-libs/gtk-vnc
parentUnmask some GNOME 3 libraries that are either slotted, or safe (diff)
downloadgentoo-2-eb73937a5ce1fa6fd40772ad559a6a3e157dfea5.tar.gz
gentoo-2-eb73937a5ce1fa6fd40772ad559a6a3e157dfea5.tar.bz2
gentoo-2-eb73937a5ce1fa6fd40772ad559a6a3e157dfea5.zip
Bump to 0.4.3-r1 with gtk3 support, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/ChangeLog8
-rw-r--r--net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch21
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild128
-rw-r--r--net-libs/gtk-vnc/metadata.xml1
4 files changed, 157 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 70042ab7e215..1457127a0cf5 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.67 2011/08/13 18:03:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.68 2011/08/16 14:28:58 nirbheek Exp $
+
+*gtk-vnc-0.4.3-r1 (16 Aug 2011)
+
+ 16 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +gtk-vnc-0.4.3-r1.ebuild,
+ +files/gtk-vnc-0.4.3-outoftree-build.patch, metadata.xml:
+ Bump to 0.4.3-r1 with gtk3 support, from gnome overlay for GNOME 3
13 Aug 2011; Raúl Porcel <armin76@gentoo.org> gtk-vnc-0.4.3.ebuild:
alpha/ia64/sparc stable wrt #369909
diff --git a/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch b/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch
new file mode 100644
index 000000000000..36a3a3a9e158
--- /dev/null
+++ b/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch
@@ -0,0 +1,21 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 37f8444..2f72fa6 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -279,14 +279,14 @@ GVNC_INTROSPECTION_SRCS = \
+ $(srcdir)/vnccolormap.h $(srcdir)/vnccolormap.c \
+ $(srcdir)/vnccursor.h $(srcdir)/vnccursor.c \
+ $(srcdir)/vncconnection.h $(srcdir)/vncconnection.c \
+- $(builddir)/vncconnectionenums.h $(builddir)/vncconnectionenums.c \
++ $(srcdir)/vncconnectionenums.h $(srcdir)/vncconnectionenums.c \
+ $(srcdir)/vncutil.h $(srcdir)/vncutil.c
+
+ GTK_VNC_INTROSPECTION_SRCS = \
+ $(srcdir)/vnccairoframebuffer.h $(srcdir)/vnccairoframebuffer.c \
+ $(srcdir)/vncdisplay.h $(srcdir)/vncdisplay.c \
+ $(srcdir)/vncgrabsequence.h $(srcdir)/vncgrabsequence.c \
+- $(builddir)/vncdisplayenums.h $(builddir)/vncdisplayenums.c
++ $(srcdir)/vncdisplayenums.h $(srcdir)/vncdisplayenums.c
+
+ if HAVE_GTK_2
+ GTK_VNC_INTROSPECTION_SRCS += \
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..6b81b362c2e3
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild,v 1.1 2011/08/16 14:28:58 nirbheek Exp $
+
+EAPI="3"
+
+inherit autotools eutils base gnome.org python
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="http://live.gnome.org/gtk-vnc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples gtk3 +introspection python sasl"
+
+# libview is used in examples/gvncviewer -- no need
+# TODO: review nsplugin when it will be considered less experimental
+
+COMMON_DEPEND=">=dev-libs/glib-2.10:2
+ >=net-libs/gnutls-1.4
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
+ python? ( >=dev-python/pygtk-2:2 )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40"
+
+GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
+GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ mkdir "${GTK2_BUILDDIR}" || die
+ mkdir "${GTK3_BUILDDIR}" || die
+
+ # Fix incorrect rules for out of tree build
+ epatch "${FILESDIR}/${PN}-0.4.3-outoftree-build.patch"
+
+ # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk
+ sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
+ -i src/Makefile.* || die
+
+ intltoolize --force --copy --automake || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ myconf="
+ $(use_with examples) \
+ $(use_enable introspection) \
+ $(use_with sasl) \
+ --with-coroutine=gthread \
+ --without-libview \
+ --disable-static"
+
+ cd ${GTK2_BUILDDIR}
+ einfo "Running configure in ${GTK2_BUILDDIR}"
+ ECONF_SOURCE="${S}" econf ${myconf} \
+ $(use_with python) \
+ --with-gtk=2.0
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running configure in ${GTK3_BUILDDIR}"
+ # Python support is via gobject-introspection
+ # Ex: from gi.repository import GtkVnc
+ ECONF_SOURCE="${S}" econf ${myconf} \
+ --with-python=no \
+ --with-gtk=3.0
+ fi
+}
+
+src_compile() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make in ${GTK2_BUILDDIR}"
+ emake || die
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make in ${GTK3_BUILDDIR}"
+ emake || die
+ fi
+}
+
+src_test() {
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make check in ${GTK2_BUILDDIR}"
+ emake check || die
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make check in ${GTK3_BUILDDIR}"
+ emake check || die
+ fi
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ cd ${GTK2_BUILDDIR}
+ einfo "Running make install in ${GTK2_BUILDDIR}"
+ # bug #328273
+ MAKEOPTS="${MAKEOPTS} -j1" base_src_install
+
+ if use gtk3; then
+ cd ${GTK3_BUILDDIR}
+ einfo "Running make install in ${GTK3_BUILDDIR}"
+ # bug #328273
+ MAKEOPTS="${MAKEOPTS} -j1" base_src_install
+ fi
+
+ python_clean_installation_image
+
+ # Remove .la files
+ find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+}
diff --git a/net-libs/gtk-vnc/metadata.xml b/net-libs/gtk-vnc/metadata.xml
index 0b6b5da045eb..21064efa27ad 100644
--- a/net-libs/gtk-vnc/metadata.xml
+++ b/net-libs/gtk-vnc/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
+ <flag name="gtk3">Build the gtk3 gtk-vnc library and other gtk3 assets</flag>
<flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
for introspection</flag>
</use>