summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-29 23:24:22 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-29 23:24:22 +0000
commited3762b55141f730112b6238005110bfb71afdbf (patch)
treeb9a3729302a72634fa801ddce3952d72e54d21d3 /net-irc
parentFixed so the configure script does the right thing when ssl is used. (diff)
downloadgentoo-2-ed3762b55141f730112b6238005110bfb71afdbf.tar.gz
gentoo-2-ed3762b55141f730112b6238005110bfb71afdbf.tar.bz2
gentoo-2-ed3762b55141f730112b6238005110bfb71afdbf.zip
new snapshot
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/digest-xchat-200205271
-rw-r--r--net-irc/xchat/xchat-20020527.ebuild81
3 files changed, 87 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 283cdd5a2e58..ce7763a60284 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.6 2002/05/27 15:18:02 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.7 2002/05/29 23:24:22 spider Exp $
+*xchat-20020527 (29 May 2002)
+ 29 May 2002; Spider <spider@gentoo.org> xchat-20020527.ebuild
+ new snapshot
+
*xchat-20020519 (27 May 2002)
27 May 2002; Spider <spider@gentoo.org> xchat-20020519.ebuild
xchat ebuild written to work with GNOME2 or just GTK+2
diff --git a/net-irc/xchat/files/digest-xchat-20020527 b/net-irc/xchat/files/digest-xchat-20020527
new file mode 100644
index 000000000000..13753fc2c9ea
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-20020527
@@ -0,0 +1 @@
+MD5 69f7ac2232e3a9a24f8d7f923e41e56f xchat-20020527.tar.bz2 667496
diff --git a/net-irc/xchat/xchat-20020527.ebuild b/net-irc/xchat/xchat-20020527.ebuild
new file mode 100644
index 000000000000..0989839628a6
--- /dev/null
+++ b/net-irc/xchat/xchat-20020527.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-20020527.ebuild,v 1.1 2002/05/29 23:24:22 spider Exp $
+
+# Python is DISABLED
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+LICENSE="GPL-2"
+SLOT=0
+
+RDEPEND=">=dev-libs/glib-2.0.1
+ >=x11-libs/gtk+-2.0.1
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=x11-libs/libzvt-1.115.2
+ >=gnome-base/libgnome-1.117.1
+ >=gnome-base/gnome-applets-1.103.0
+ >=gnome-base/gnome-panel-1.5.22 )"
+
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+
+ local myopts myflags
+
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ || myopts="${myopts} --disable-gnome"
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr utildir=${D}${KDEDIR}/share/applnk/Internet install || die
+
+ use gnome &&
+ ( insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}