summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-09-03 10:19:00 +0000
committerIan Delaney <idella4@gentoo.org>2013-09-03 10:19:00 +0000
commit2336367538667f42c82961f58975a534f0e7f471 (patch)
tree2502af352174623edd1d336f4d1155652b21cc65 /net-irc
parentversion bump (diff)
downloadgentoo-2-2336367538667f42c82961f58975a534f0e7f471.tar.gz
gentoo-2-2336367538667f42c82961f58975a534f0e7f471.tar.bz2
gentoo-2-2336367538667f42c82961f58975a534f0e7f471.zip
revbump -> EAPI 5, remove old
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/pisg/ChangeLog10
-rw-r--r--net-irc/pisg/pisg-0.72.ebuild55
-rw-r--r--net-irc/pisg/pisg-0.73-r1.ebuild52
3 files changed, 60 insertions, 57 deletions
diff --git a/net-irc/pisg/ChangeLog b/net-irc/pisg/ChangeLog
index f9f311dd829e..1d1d46aa45e0 100644
--- a/net-irc/pisg/ChangeLog
+++ b/net-irc/pisg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/pisg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.63 2012/08/03 21:46:13 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.64 2013/09/03 10:18:59 idella4 Exp $
+
+*pisg-0.73-r1 (03 Sep 2013)
+
+ 03 Sep 2013; Ian Delaney <idella4@gentoo.org> +pisg-0.73-r1.ebuild,
+ -pisg-0.72.ebuild:
+ revbump -> EAPI 5, remove old
03 Aug 2012; Anthony G. Basile <blueness@gentoo.org> pisg-0.73.ebuild:
Stable ppc, bug #419249
diff --git a/net-irc/pisg/pisg-0.72.ebuild b/net-irc/pisg/pisg-0.72.ebuild
deleted file mode 100644
index 040f42902b41..000000000000
--- a/net-irc/pisg/pisg-0.72.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/pisg-0.72.ebuild,v 1.4 2008/08/31 15:00:43 armin76 Exp $
-
-inherit perl-app
-
-DESCRIPTION="Perl IRC Statistics Generator"
-HOMEPAGE="http://pisg.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
-IUSE=""
-
-RDEPEND="dev-lang/perl
- dev-perl/Text-Iconv"
-DEPEND="dev-lang/perl
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
-
- sed -i \
- -e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
- -e 's!layout/!/usr/share/pisg/layout/!' \
- "${S}"/modules/Pisg.pm \
- || die "sed failed"
-}
-
-src_compile() {
- einfo "Nothing to compile"
-}
-
-src_install() {
- perlinfo
-
- dobin pisg || die "dobin failed"
-
- insinto "${VENDOR_LIB}"
- doins -r modules/. || die "doins failed"
-
- insinto /usr/share/pisg
- doins -r gfx layout lang.txt || die "doins failed"
-
- dodoc \
- docs/{CREDITS,Changelog,FORMATS,pisg-doc.txt} \
- docs/dev/API pisg.cfg README || die "dodoc failed"
- doman docs/pisg.1 || die "doman failed"
- dohtml docs/pisg-doc.html || die "dohtml failed"
-}
-
-pkg_postinst() {
- einfo "The pisg images have been installed in /usr/share/pisg/gfx"
-}
diff --git a/net-irc/pisg/pisg-0.73-r1.ebuild b/net-irc/pisg/pisg-0.73-r1.ebuild
new file mode 100644
index 000000000000..30c111094c4c
--- /dev/null
+++ b/net-irc/pisg/pisg-0.73-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/pisg-0.73-r1.ebuild,v 1.1 2013/09/03 10:18:59 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Perl IRC Statistics Generator"
+HOMEPAGE="http://pisg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+RDEPEND="dev-perl/Text-Iconv"
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i \
+ -e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
+ -e 's!layout/!/usr/share/pisg/layout/!' \
+ modules/Pisg.pm || die "sed failed"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ perlinfo
+
+ dobin pisg || die "dobin failed"
+
+ insinto "${VENDOR_LIB}"
+ doins -r modules/.
+
+ insinto /usr/share/pisg
+ doins -r gfx layout lang.txt
+
+ dodoc docs/{FORMATS,pisg-doc.txt} \
+ docs/dev/API pisg.cfg README
+ doman docs/pisg.1
+ dohtml docs/pisg-doc.html
+}
+
+pkg_postinst() {
+ einfo "The pisg images have been installed in /usr/share/pisg/gfx"
+}