summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-06 17:50:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-06 17:50:05 +0000
commit13dc2a1c22a986c00664f97380c2f1e789cb32ce (patch)
tree6252fd6e3c3f6003f8914ca4e7f3e48df9700f44 /net-irc
parentstable amd64, bug 228449 (diff)
downloadgentoo-2-13dc2a1c22a986c00664f97380c2f1e789cb32ce.tar.gz
gentoo-2-13dc2a1c22a986c00664f97380c2f1e789cb32ce.tar.bz2
gentoo-2-13dc2a1c22a986c00664f97380c2f1e789cb32ce.zip
Add patch from upstream, bug #230451
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/xc286-smallfixes.diff68
-rw-r--r--net-irc/xchat/xchat-2.8.6-r1.ebuild (renamed from net-irc/xchat/xchat-2.8.6.ebuild)4
3 files changed, 78 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index b3d125f84011..918df4a6badb 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.265 2008/06/13 09:56:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.266 2008/07/06 17:50:05 armin76 Exp $
+
+*xchat-2.8.6-r1 (06 Jul 2008)
+
+ 06 Jul 2008; Raúl Porcel <armin76@gentoo.org>
+ +files/xc286-smallfixes.diff, -xchat-2.8.6.ebuild, +xchat-2.8.6-r1.ebuild:
+ Add patch from upstream, bug #230451
*xchat-2.8.6 (13 Jun 2008)
diff --git a/net-irc/xchat/files/xc286-smallfixes.diff b/net-irc/xchat/files/xc286-smallfixes.diff
new file mode 100644
index 000000000000..da9001522fd8
--- /dev/null
+++ b/net-irc/xchat/files/xc286-smallfixes.diff
@@ -0,0 +1,68 @@
+#
+# Various small fixes from CVS that are considered safe to apply to 2.8.6.
+#
+--- xchat-2.8.6/src/common/cfgfiles.c 2008-02-05 21:02:47.000000000 +1100
++++ xchat-2.8.6p1/src/common/cfgfiles.c 2008-06-15 13:45:43.000000000 +1000
+@@ -886,7 +886,6 @@
+ set_showval (session *sess, const struct prefs *var, char *tbuf)
+ {
+ int len, dots, j;
+- static const char *offon[] = { "OFF", "ON" };
+
+ len = strlen (var->name);
+ memcpy (tbuf, var->name, len);
+@@ -909,8 +908,10 @@
+ *((int *) &prefs + var->offset));
+ break;
+ case TYPE_BOOL:
+- sprintf (tbuf + len, "\0033:\017 %s\n", offon[
+- *((int *) &prefs + var->offset)]);
++ if (*((int *) &prefs + var->offset))
++ sprintf (tbuf + len, "\0033:\017 %s\n", "ON");
++ else
++ sprintf (tbuf + len, "\0033:\017 %s\n", "OFF");
+ break;
+ }
+ PrintText (sess, tbuf);
+--- xchat-2.8.6/src/common/chanopt.c 2008-06-10 22:00:55.000000000 +1000
++++ xchat-2.8.6p1/src/common/chanopt.c 2008-06-15 13:48:04.000000000 +1000
+@@ -32,7 +32,7 @@
+
+ #define S_F(xx) STRUCT_OFFSET_STR(struct session,xx)
+
+-channel_options chanopt[] =
++static const channel_options chanopt[] =
+ {
+ {"alert_beep", "BEEP", S_F(alert_beep)},
+ {"alert_taskbar", NULL, S_F(alert_taskbar)},
+--- xchat-2.8.6/src/common/servlist.c 2008-04-01 19:22:34.000000000 +1100
++++ xchat-2.8.6p1/src/common/servlist.c 2008-06-15 13:57:41.000000000 +1000
+@@ -509,6 +509,8 @@
+ list = g_slist_nth (net->servlist, net->selected);
+ if (!list)
+ list = net->servlist;
++ if (!list)
++ return;
+ ircserv = list->data;
+
+ /* incase a protocol switch is added to the servlist gui */
+--- xchat-2.8.6/src/common/text.c 2008-03-28 13:20:04.000000000 +1100
++++ xchat-2.8.6p1/src/common/text.c 2008-06-15 13:59:59.000000000 +1000
+@@ -216,7 +216,7 @@
+ static void
+ scrollback_save (session *sess, char *text)
+ {
+- char buf[1024];
++ char buf[512 * 4];
+ time_t stamp;
+ int len;
+
+@@ -266,7 +266,7 @@
+ scrollback_load (session *sess)
+ {
+ int fh;
+- char buf[1024];
++ char buf[512 * 4];
+ char *text;
+ time_t stamp;
+ int lines;
diff --git a/net-irc/xchat/xchat-2.8.6.ebuild b/net-irc/xchat/xchat-2.8.6-r1.ebuild
index be12ff454ee5..fcc9ed7ed1ba 100644
--- a/net-irc/xchat/xchat-2.8.6.ebuild
+++ b/net-irc/xchat/xchat-2.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.6.ebuild,v 1.1 2008/06/13 09:56:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.6-r1.ebuild,v 1.1 2008/07/06 17:50:05 armin76 Exp $
inherit eutils versionator gnome2
@@ -41,6 +41,8 @@ src_unpack() {
sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
"${S}"/configure{,.in} || die
fi
+
+ epatch "${FILESDIR}"/xc286-smallfixes.diff
}
src_compile() {