summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-02 03:53:23 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-02 03:53:23 +0000
commit0d2e909126a00fae6ed2cbd3f9f3504c5e1a1ea5 (patch)
treec5cb630b4bfb592ba1c5d5a53f8cb05e1ccd432c /net-irc
parentStable for HPPA (bug #475480). (diff)
downloadgentoo-2-0d2e909126a00fae6ed2cbd3f9f3504c5e1a1ea5.tar.gz
gentoo-2-0d2e909126a00fae6ed2cbd3f9f3504c5e1a1ea5.tar.bz2
gentoo-2-0d2e909126a00fae6ed2cbd3f9f3504c5e1a1ea5.zip
Security bump wrt bug 482582.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ngircd/ChangeLog10
-rw-r--r--net-irc/ngircd/ngircd-20.3.ebuild81
2 files changed, 88 insertions, 3 deletions
diff --git a/net-irc/ngircd/ChangeLog b/net-irc/ngircd/ChangeLog
index bc04ed25e2dd..d78ffe808534 100644
--- a/net-irc/ngircd/ChangeLog
+++ b/net-irc/ngircd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/ngircd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.55 2011/09/22 11:29:53 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.56 2013/10/02 03:53:23 creffett Exp $
+
+*ngircd-20.3 (02 Oct 2013)
+
+ 02 Oct 2013; Chris Reffett <creffett@gentoo.org> +ngircd-20.3.ebuild:
+ Security bump wrt bug 482582.
22 Sep 2011; Kacper Kowalik <xarthisius@gentoo.org> ngircd-0.12.1.ebuild,
ngircd-13.ebuild, ngircd-17.1.ebuild, ngircd-18.ebuild:
@@ -211,4 +216,3 @@
19 Apr 2004; Chuck Short <zul@gentoo.org> :
Initial version, ebuild written by me. Closes #47945.
-
diff --git a/net-irc/ngircd/ngircd-20.3.ebuild b/net-irc/ngircd/ngircd-20.3.ebuild
new file mode 100644
index 000000000000..fd6836117ddc
--- /dev/null
+++ b/net-irc/ngircd/ngircd-20.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ngircd-20.3.ebuild,v 1.1 2013/10/02 03:53:23 creffett Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A IRC server written from scratch"
+HOMEPAGE="http://ngircd.barton.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/${PN}/${P}.tar.gz
+ ftp://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gnutls ident ipv6 pam ssl tcpd zlib"
+
+RDEPEND="
+ ident? ( net-libs/libident )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+"
+
+RESTRICT="test"
+
+src_configure() {
+ if ! use prefix; then
+ sed -i \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+ doc/sample-ngircd.conf.tmpl || die
+ fi
+
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --sysconfdir="${EPREFIX}"/etc/ngircd
+ $(use_enable ipv6)
+ $(use_with zlib)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with ident)
+ $(use_with pam)
+ $(use_enable debug)
+ $(use_enable debug sniffer)
+ )
+
+ if use ssl; then
+ myeconfargs+=(
+ $(use_with !gnutls openssl)
+ $(use_with gnutls)
+ )
+ else
+ myeconfargs+=(
+ --without-gnutls
+ --without-ssl
+ )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/ngircd.init.d ngircd
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ enewuser ngircd
+ chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
+ fi
+}