summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-01-21 18:12:08 +0000
committerSven Wegener <swegener@gentoo.org>2005-01-21 18:12:08 +0000
commit016ad2f388cccf02577aeb3d8c4f3c99635449b2 (patch)
tree7ce58cebd02b03152ab0176b32ad869b23f7be8f /net-irc
parentRemoved soon-to-be-obsolete virtuals. (diff)
downloadgentoo-2-016ad2f388cccf02577aeb3d8c4f3c99635449b2.tar.gz
gentoo-2-016ad2f388cccf02577aeb3d8c4f3c99635449b2.tar.bz2
gentoo-2-016ad2f388cccf02577aeb3d8c4f3c99635449b2.zip
Pull in all CVS changes from 0.8.10_rc5 to now. Includes several bugfixes (logging, memleak and more), updated help (recode) and some new features. Read upstream's ChangeLog for more information. Closes bug #78917.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi/ChangeLog10
-rw-r--r--net-irc/irssi/files/digest-irssi-0.8.10_rc5-r12
-rw-r--r--net-irc/irssi/irssi-0.8.10_rc5-r1.ebuild86
3 files changed, 97 insertions, 1 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index 488e45284ebe..3d0f81259620 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/irssi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.56 2005/01/07 00:47:04 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.57 2005/01/21 18:12:08 swegener Exp $
+
+*irssi-0.8.10_rc5-r1 (21 Jan 2005)
+
+ 21 Jan 2005; Sven Wegener <swegener@gentoo.org>
+ +irssi-0.8.10_rc5-r1.ebuild:
+ Pull in all CVS changes from 0.8.10_rc5 to now. Includes several bugfixes
+ (logging, memleak and more), updated help (recode) and some new features.
+ Read upstream's ChangeLog for more information. Closes bug #78917.
07 Jan 2005; Sven Wegener <swegener@gentoo.org> irssi-0.8.10_rc5.ebuild:
Removed blockers on irssi-charconv and irssi-recode.
diff --git a/net-irc/irssi/files/digest-irssi-0.8.10_rc5-r1 b/net-irc/irssi/files/digest-irssi-0.8.10_rc5-r1
new file mode 100644
index 000000000000..034a3743ac32
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.8.10_rc5-r1
@@ -0,0 +1,2 @@
+MD5 7c0b6c1533c85e918f41ded1238e4ca1 irssi-0.8.10-rc5.tar.gz 1192158
+MD5 90e394fa2a4cc8d055afc66cde47ba0a irssi-0.8.10_rc5-CVS-20050121.patch.bz2 17705
diff --git a/net-irc/irssi/irssi-0.8.10_rc5-r1.ebuild b/net-irc/irssi/irssi-0.8.10_rc5-r1.ebuild
new file mode 100644
index 000000000000..6a2697da5672
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.10_rc5-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.10_rc5-r1.ebuild,v 1.1 2005/01/21 18:12:08 swegener Exp $
+
+inherit perl-module eutils
+
+MY_P="${P//_/-}"
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="http://irssi.org/"
+SRC_URI="http://irssi.org/files/${MY_P}.tar.gz
+ mirror://gentoo/${P}-CVS-20050121.patch.bz2
+ http://dev.gentoo.org/~swegener/distfiles/${P}-CVS-20050121.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nls ipv6 perl ssl socks5"
+
+RDEPEND="!net-irc/irssi-cvs
+ >=dev-libs/glib-2.2.1
+ sys-libs/ncurses
+ ssl? ( dev-libs/openssl )
+ perl? ( dev-lang/perl )
+ socks5? ( >=net-misc/dante-1.1.13 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Ugly hack to work around compression of the html files.
+ # Remove this if prepalldocs is changed to avoid gzipping html files.
+ sed -i \
+ -e 's/[^ ]\+\.html//g' docs/Makefile.in || \
+ die "sed doc/Makefile.in failed"
+
+ epatch ${WORKDIR}/${P}-CVS-20050121.patch
+}
+
+src_compile() {
+ if use ssl
+ then
+ myconf="--with-openssl-include=/usr --with-openssl-libs=/usr"
+ else
+ myconf="--disable-ssl"
+ fi
+
+ econf \
+ --with-glib2 \
+ --without-servertest \
+ --with-proxy \
+ --with-ncurses \
+ $(use_enable nls) \
+ $(use_with perl) \
+ $(use_enable ipv6) \
+ $(use_with socks5 socks) \
+ ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use perl
+ then
+ for dir in ${S}/src/perl/{common,irc,textui,ui}
+ do
+ cd ${dir}
+ perl-module_src_prep
+ done
+ cd ${S}
+ fi
+
+ make \
+ DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die "make install failed"
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog README TODO NEWS || die "dodoc failed"
+ dohtml -r ${S}/docs/. || die "dohtml failed"
+}