summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-01-04 20:22:32 +0000
committerSven Wegener <swegener@gentoo.org>2007-01-04 20:22:32 +0000
commit80b3c6c5c50c40c57d36f228ef4614f2e3e7f1f5 (patch)
treec130f8ec90a8d2a310c38fee76825f064f5c6825 /net-irc/xchat
parentprune old versions (diff)
downloadgentoo-2-80b3c6c5c50c40c57d36f228ef4614f2e3e7f1f5.tar.gz
gentoo-2-80b3c6c5c50c40c57d36f228ef4614f2e3e7f1f5.tar.bz2
gentoo-2-80b3c6c5c50c40c57d36f228ef4614f2e3e7f1f5.zip
Version bump.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-2.8.06
-rw-r--r--net-irc/xchat/files/xc280-fix-back.diff14
-rw-r--r--net-irc/xchat/xchat-2.8.0.ebuild88
4 files changed, 116 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index b77d545690cd..9e0eb32871ea 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.221 2006/12/25 15:02:55 hanno Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.222 2007/01/04 20:22:32 swegener Exp $
+
+*xchat-2.8.0 (04 Jan 2007)
+
+ 04 Jan 2007; Sven Wegener <swegener@gentoo.org>
+ +files/xc280-fix-back.diff, +xchat-2.8.0.ebuild:
+ Version bump.
*xchat-2.6.8-r3 (25 Dec 2006)
diff --git a/net-irc/xchat/files/digest-xchat-2.8.0 b/net-irc/xchat/files/digest-xchat-2.8.0
new file mode 100644
index 000000000000..dfa385249197
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.8.0
@@ -0,0 +1,6 @@
+MD5 dddb703d1daf9be7a7bc9461cf11ede7 xchat-2.8.0.tar.bz2 1257232
+RMD160 a65329728c050c5448b2cbab2ea6c68ba72a0c95 xchat-2.8.0.tar.bz2 1257232
+SHA256 f417891d2405980875fd3ce03eb78f8e2ad3ea7354df8b7bb0a2939a55e20906 xchat-2.8.0.tar.bz2 1257232
+MD5 c0220456a4df8ee54ae02e7704a6e024 xchat-dccserver-0.6.patch.bz2 49320
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/files/xc280-fix-back.diff b/net-irc/xchat/files/xc280-fix-back.diff
new file mode 100644
index 000000000000..c63316c83707
--- /dev/null
+++ b/net-irc/xchat/files/xc280-fix-back.diff
@@ -0,0 +1,14 @@
+#
+# Fix: /BACK command not working after upgrading from xchat < 2.8.0
+#
+--- xchat-2.8.0/src/common/cfgfiles.c 2 Jan 2007 00:26:40 -0000 1.102
++++ xchat-2.8.0p1/src/common/cfgfiles.c 3 Jan 2007 14:01:00 -0000
+@@ -45,7 +45,7 @@
+ int cmd_len = 1, name_len;
+
+ /* remove <2.8.0 stuff */
+- if (!strcmp (cmd, "AWAY") & !strcmp (name, "BACK"))
++ if (!strcmp (cmd, "away") & !strcmp (name, "BACK"))
+ return;
+
+ if (cmd)
diff --git a/net-irc/xchat/xchat-2.8.0.ebuild b/net-irc/xchat/xchat-2.8.0.ebuild
new file mode 100644
index 000000000000..d1e27fc42576
--- /dev/null
+++ b/net-irc/xchat/xchat-2.8.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.0.ebuild,v 1.1 2007/01/04 20:22:32 swegener Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ xchatdccserver? ( mirror://gentoo/${PN}-dccserver-0.6.patch.bz2 )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl dbus tcl python ssl mmx ipv6 nls spell xchattext xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.6.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 ) ) )
+ spell? ( app-text/enchant )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ epatch "${FILESDIR}"/xc280-fix-back.diff
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [[ ${ARCH} = sparc ]] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell spell static) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "XChat binary has been renamed from xchat-2 to xchat."
+}