summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-06 13:16:41 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-06 13:16:41 +0000
commit9e91eda2f074d452e320d2b7e15e9c177e11d256 (patch)
tree50b7303f71ea692f95607141be576e509f0c8c3b /net-irc/anope
parentver bump (diff)
downloadgentoo-2-9e91eda2f074d452e320d2b7e15e9c177e11d256.tar.gz
gentoo-2-9e91eda2f074d452e320d2b7e15e9c177e11d256.tar.bz2
gentoo-2-9e91eda2f074d452e320d2b7e15e9c177e11d256.zip
Version bump
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/ChangeLog7
-rw-r--r--net-irc/anope/anope-1.7.19.ebuild145
-rw-r--r--net-irc/anope/files/digest-anope-1.7.193
3 files changed, 154 insertions, 1 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index 243fa0f55669..8ccd43954350 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/anope
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.6 2007/04/21 22:03:18 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.7 2007/09/06 13:16:41 jokey Exp $
+
+*anope-1.7.19 (06 Sep 2007)
+
+ 06 Sep 2007; Markus Ullmann <jokey@gentoo.org> +anope-1.7.19.ebuild:
+ Version bump
21 Apr 2007; Bjarke Istrup Pedersen <gurligebis@gentoo.org> anope-1.7.18.ebuild:
replacing insinto with newconfd and newinitd functions
diff --git a/net-irc/anope/anope-1.7.19.ebuild b/net-irc/anope/anope-1.7.19.ebuild
new file mode 100644
index 000000000000..9c78cfd91a8a
--- /dev/null
+++ b/net-irc/anope/anope-1.7.19.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.7.19.ebuild,v 1.1 2007/09/06 13:16:41 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Anope IRC Services"
+HOMEPAGE="http://www.anope.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql"
+
+DEPEND="mysql? ( virtual/mysql )"
+
+INSTALL_DIR="/opt/anope"
+
+pkg_setup() {
+ enewgroup anope
+ enewuser anope -1 -1 ${INSTALL_DIR} anope
+ if has_version net-irc/anope ; then
+ ewarn
+ ewarn "Make backups before updating as they will be overwritten"
+ ewarn
+ ebeep 10
+ fi
+}
+
+src_compile() {
+ local myconf
+ if ! use mysql; then
+ myconf="${myconf} --without-mysql"
+ fi
+
+ epatch ${FILESDIR}/pid-patch.diff
+
+ econf \
+ ${myconf} \
+ --bindir ${INSTALL_DIR} \
+ --with-bindir=${INSTALL_DIR} \
+ --with-datadir=${INSTALL_DIR}/data \
+ --with-modules=${INSTALL_DIR}/modules \
+ --with-encryption \
+ --with-rungroup=anope \
+ --with-permissions=077 \
+ || die "Configuration failed."
+
+ sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
+
+ emake || die "Make failed."
+}
+
+src_install() {
+ dodir ${INSTALL_DIR}
+ dodir ${INSTALL_DIR}/data
+ dodir ${INSTALL_DIR}/data/logs
+ dodir ${INSTALL_DIR}/data/languages
+ dodir ${INSTALL_DIR}/data/modules
+ dodir ${INSTALL_DIR}/data/modules/runtime
+ dodir ${INSTALL_DIR}/modules
+
+ dodir /var/run/anope
+ fowners anope:anope /var/run/anope
+ keepdir /var/run/anope
+
+ fowners anope:anope ${INSTALL_DIR}
+ fowners anope:anope ${INSTALL_DIR}/data
+ fowners anope:anope ${INSTALL_DIR}/data/logs
+ fowners anope:anope ${INSTALL_DIR}/data/languages
+ fowners anope:anope ${INSTALL_DIR}/data/modules
+ fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
+ fowners anope:anope ${INSTALL_DIR}/modules
+
+ exeinto ${INSTALL_DIR}
+ doexe src/services
+#### insinto ${INSTALL_DIR}/data
+#### newins data/example.conf services.conf
+
+ newinitd ${FILESDIR}/anope.initd anope
+ newconfd ${FILESDIR}/anope.confd anope
+
+ insinto ${INSTALL_DIR}/modules
+ doins src/modules/*.so
+
+ keepdir ${INSTALL_DIR}/data/logs
+
+ insinto ${INSTALL_DIR}/data/languages
+ doins lang/cat
+ doins lang/de
+ doins lang/en_us
+ doins lang/es
+ doins lang/fr
+ doins lang/gr
+ doins lang/hun
+ doins lang/it
+ doins lang/nl
+ doins lang/pl
+ doins lang/pt
+ doins lang/ru
+ doins lang/tr
+
+ keepdir ${INSTALL_DIR}/data/modules/runtime
+
+ insinto ${INSTALL_DIR}/data/modules
+ doins src/protocol/*.so
+ doins src/core/*.so
+
+ fowners anope:anope ${INSTALL_DIR}/services
+ fowners anope:anope ${INSTALL_DIR}/data/services.conf
+ fowners anope:anope ${INSTALL_DIR}/data/languages/cat
+ fowners anope:anope ${INSTALL_DIR}/data/languages/de
+ fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
+ fowners anope:anope ${INSTALL_DIR}/data/languages/fr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/gr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/hun
+ fowners anope:anope ${INSTALL_DIR}/data/languages/it
+ fowners anope:anope ${INSTALL_DIR}/data/languages/nl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pt
+ fowners anope:anope ${INSTALL_DIR}/data/languages/ru
+ fowners anope:anope ${INSTALL_DIR}/data/languages/tr
+
+ dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
+}
+
+pkg_preinst() {
+ if has_version net-irc/anope ; then
+ elog "Making a backup of your config to data/pre-update"
+ mkdir ${ROOT}opt/anope/data/pre-update
+ cp ${ROOT}opt/anope/data/* ${ROOT}opt/anope/data/pre-update
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
+ ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
+ echo
+ ewarn "!!! ATTENTION !!!"
+ ewarn "If you had used 1.7.15 before, be sure to read Changes.mysql to update your MySQL"
+ ewarn "tables or anope will break after restart"
+ ewarn "!!! ATTENTION !!!"
+}
diff --git a/net-irc/anope/files/digest-anope-1.7.19 b/net-irc/anope/files/digest-anope-1.7.19
new file mode 100644
index 000000000000..14394d497769
--- /dev/null
+++ b/net-irc/anope/files/digest-anope-1.7.19
@@ -0,0 +1,3 @@
+MD5 a517809e81cc83f52d411fdcb52e1305 anope-1.7.19.tar.gz 1505639
+RMD160 01169edef64bacfb5a8e92710d62e1796752ddf4 anope-1.7.19.tar.gz 1505639
+SHA256 2717588ba3b14b6b7d5061f82a0b021553d23ca7f1dff945abd8cafd73a0674a anope-1.7.19.tar.gz 1505639