summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-08-31 15:11:48 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-08-31 15:11:48 +0000
commit61a3b24653b89edfd3d0bd8a80b8e7ae56571d5c (patch)
treec1330d8e4bd011e574f2876ded7a11b382e3f5d6 /net-im
parentversion bump(s) (Manifest recommit) (diff)
downloadgentoo-2-61a3b24653b89edfd3d0bd8a80b8e7ae56571d5c.tar.gz
gentoo-2-61a3b24653b89edfd3d0bd8a80b8e7ae56571d5c.tar.bz2
gentoo-2-61a3b24653b89edfd3d0bd8a80b8e7ae56571d5c.zip
initial import
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-plugin/ChangeLog9
-rw-r--r--net-im/silc-plugin/metadata.xml9
-rw-r--r--net-im/silc-plugin/silc-plugin-1.0.1.ebuild95
3 files changed, 113 insertions, 0 deletions
diff --git a/net-im/silc-plugin/ChangeLog b/net-im/silc-plugin/ChangeLog
new file mode 100644
index 000000000000..953ed049bc09
--- /dev/null
+++ b/net-im/silc-plugin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/silc-plugin
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/ChangeLog,v 1.1 2004/08/31 15:11:48 ticho Exp $
+
+*silc-plugin-1.0.1 (31 Aug 2004)
+
+ 31 Aug 2004; <ticho@gentoo.org> +metadata.xml, +silc-plugin-1.0.1.ebuild:
+ Initial import, from bug #61189. Marked unstable on x86 and sparc.
+
diff --git a/net-im/silc-plugin/metadata.xml b/net-im/silc-plugin/metadata.xml
new file mode 100644
index 000000000000..e149b8a18631
--- /dev/null
+++ b/net-im/silc-plugin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<maintainer>
+ <email>ticho@gentoo.org</email>
+<description>A SILC plugin for Irssi</description>
+</maintainer>
+</pkgmetadata>
diff --git a/net-im/silc-plugin/silc-plugin-1.0.1.ebuild b/net-im/silc-plugin/silc-plugin-1.0.1.ebuild
new file mode 100644
index 000000000000..8d054ed2f061
--- /dev/null
+++ b/net-im/silc-plugin/silc-plugin-1.0.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/silc-plugin-1.0.1.ebuild,v 1.1 2004/08/31 15:11:48 ticho Exp $
+
+IRSSI_PV=0.8.9
+
+DESCRIPTION="A SILC plugin for Irssi"
+HOMEPAGE="http://penguin-breeder.org/silc/"
+SRC_URI="http://irssi.org/files/irssi-${IRSSI_PV}.tar.bz2
+ http://silcnet.org/download/client/sources/silc-client-${PV}.tar.gz
+ http://penguin-breeder.org/silc/download/silc-plugin-${PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="debug pic"
+
+# All necessary dependencies are pulled in by irssi.
+DEPEND="virtual/glibc"
+RDEPEND="~net-irc/irssi-0.8.9"
+
+S_SILC="${S}/../silc-client-${PV}"
+S_IRSSI="${S}/../irssi-${IRSSI_PV}"
+
+src_compile() {
+ local myconf
+
+ echo ${S_SILC}
+ use debug && myconf="${myconf} --enable-debug"
+ use pic && myconf="${myconf} --with-pic"
+
+ echo
+ einfo "Preparing silc-client\n"
+ cd ${S_SILC}
+ econf --with-helpdir=${D}/usr/share/irssi/help/silc/ \
+ --without-libtoolfix \
+ --enable-static \
+ ${myconf}
+ make -C lib
+
+ echo
+ einfo "Patching irssi source for silc-plugin\n"
+ cd ${S}
+ make patch IRSSI=${S_IRSSI} SILC=${S_SILC}
+
+ echo
+ einfo "Configuring irssi\n"
+ cd ${S_IRSSI}
+ econf --sysconfdir=/etc
+ echo
+ einfo "Compiling silc-plugin\n"
+ make -C src/perl
+ make -C src/fe-common/silc
+ make -C src/silc/core
+}
+
+src_install() {
+ cd ${S_IRSSI}
+ make -C src/perl/silc DESTDIR=${D} install
+ make -C src/fe-common/silc DESTDIR=${D} install
+ make -C src/silc/core install DESTDIR=${D} install
+
+ cd ${S_SILC}
+ make -C irssi/docs/help install
+
+ cd ${S}
+ insinto /usr/share/irssi/scripts
+ doins scripts/*
+
+ insinto /usr/share/irssi
+ doins default.theme
+
+ dodoc AUTHORS COPYING README USAGE
+}
+
+pkg_postinst() {
+ einfo "You can load the plugin with following command in Irssi:"
+ einfo
+ einfo "\t/LOAD silc"
+ einfo
+ einfo "It will automatically generate a new key pair for you. You will be asked to"
+ einfo "enter a passphrase for this keypair twice. If you leave the passphrase"
+ einfo "empty, your key will not be stored encrypted."
+ einfo
+ einfo "You should also load the perl scripts:"
+ einfo
+ einfo "\t/SCRIPT LOAD silc"
+ einfo "\t/SCRIPT LOAD silc-mime"
+ einfo
+ einfo "To connect to the SILCNet, you can use following command in Irssi:"
+ einfo
+ einfo "\t/CONNECT -silcnet SILCNet silc.silcnet.org"
+ einfo
+ einfo "Have fun."
+}