summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-09-26 12:15:49 +0000
committerMichael Januszewski <spock@gentoo.org>2009-09-26 12:15:49 +0000
commit4c60dca1d7bbbba8dd9ffc335bd30a501760ff34 (patch)
tree3619adb14b964b62fe08be5f20f7b43f1a217e62 /net-im/tleenx2
parentFix by Jan Vansteenkiste for building with newer versions of libass #285328 b... (diff)
downloadgentoo-2-4c60dca1d7bbbba8dd9ffc335bd30a501760ff34.tar.gz
gentoo-2-4c60dca1d7bbbba8dd9ffc335bd30a501760ff34.tar.bz2
gentoo-2-4c60dca1d7bbbba8dd9ffc335bd30a501760ff34.zip
Fix bug #278242.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'net-im/tleenx2')
-rw-r--r--net-im/tleenx2/ChangeLog8
-rw-r--r--net-im/tleenx2/files/tleenx2-20060309-asneeded-fix.patch31
-rw-r--r--net-im/tleenx2/tleenx2-20060309.ebuild5
3 files changed, 40 insertions, 4 deletions
diff --git a/net-im/tleenx2/ChangeLog b/net-im/tleenx2/ChangeLog
index 20c567ef7b1e..6824e766a3f4 100644
--- a/net-im/tleenx2/ChangeLog
+++ b/net-im/tleenx2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/tleenx2
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tleenx2/ChangeLog,v 1.15 2008/12/11 15:04:49 spock Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tleenx2/ChangeLog,v 1.16 2009/09/26 12:15:48 spock Exp $
+
+ 26 Sep 2009; Michał Januszewski <spock@gentoo.org>
+ tleenx2-20060309.ebuild, +files/tleenx2-20060309-asneeded-fix.patch:
+ Fix bug #278242.
11 Dec 2008; Michał Januszewski <spock@gentoo.org>
+files/tleenx2-20060309-configure.in.patch, tleenx2-20060309.ebuild:
diff --git a/net-im/tleenx2/files/tleenx2-20060309-asneeded-fix.patch b/net-im/tleenx2/files/tleenx2-20060309-asneeded-fix.patch
new file mode 100644
index 000000000000..c9955571e767
--- /dev/null
+++ b/net-im/tleenx2/files/tleenx2-20060309-asneeded-fix.patch
@@ -0,0 +1,31 @@
+diff -Naurp TleenX2-20060309-orig/configure.in TleenX2-20060309/configure.in
+--- TleenX2-20060309-orig/configure.in 2009-09-26 13:42:22.000000000 +0200
++++ TleenX2-20060309/configure.in 2009-09-26 13:59:21.000000000 +0200
+@@ -35,7 +35,7 @@ else
+ fi
+
+ dnl We need at least 2.2 version of GTK+
+-PKG_CHECK_MODULES(PACKAGE, gtk+-2.0 >= 2.2, ,
++PKG_CHECK_MODULES(PACKAGE, [gtk+-2.0 >= 2.2 gthread-2.0 >= 2.0], ,
+ AC_MSG_ERROR([$PACKAGE_PKG_ERRORS]
+ ----------------------------------------------------------------
+ At least version 2.2 of GTK+ is required to compile TleenX2.
+@@ -51,7 +51,6 @@ if test "$have_gtk_2_8" = yes ; then
+ AC_DEFINE([GTK_2_8], ,[do we have GTK+ >= 2.8?])
+ fi
+
+-
+ dnl Use -Wall if we have gcc.
+ changequote(,)dnl
+ if test "x$GCC" = "xyes"; then
+diff -Naurp TleenX2-20060309-orig/src/Makefile.am TleenX2-20060309/src/Makefile.am
+--- TleenX2-20060309-orig/src/Makefile.am 2009-09-26 13:42:22.000000000 +0200
++++ TleenX2-20060309/src/Makefile.am 2009-09-26 13:58:53.000000000 +0200
+@@ -30,6 +30,5 @@ tleenx2_SOURCES = \
+ xmms-info.c xmms-info.h \
+ notify.c
+
+-tleenx2_LDADD = @PACKAGE_LIBS@ ../jabby/libjabby.a ../iksemel/libiksemel.a
+-tleenx2_LDFLAGS = `pkg-config --libs gthread-2.0`
++tleenx2_LDADD = @PACKAGE_LIBS@ ../jabby/libjabby.a ../iksemel/libiksemel.a
+ tleenx2_CFLAGS = -I../jabby -I../iksemel -g
diff --git a/net-im/tleenx2/tleenx2-20060309.ebuild b/net-im/tleenx2/tleenx2-20060309.ebuild
index 76a9f4d7becc..e5e7a562979a 100644
--- a/net-im/tleenx2/tleenx2-20060309.ebuild
+++ b/net-im/tleenx2/tleenx2-20060309.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/tleenx2/tleenx2-20060309.ebuild,v 1.5 2008/12/11 15:04:49 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/tleenx2/tleenx2-20060309.ebuild,v 1.6 2009/09/26 12:15:48 spock Exp $
inherit autotools eutils
@@ -27,6 +27,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/tleenx2-20060309-configure.in.patch"
+ epatch "${FILESDIR}/tleenx2-20060309-asneeded-fix.patch"
eautoreconf
}