summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-01 15:06:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-01 15:06:47 +0000
commitbc2b505dfabdca3f899c28bbb8e8490484ff68e0 (patch)
tree79885c8a810a309af7da6d4af0545fe4e0792a0a /net-im/qtwitter
parentamd64/x86 stable, bug #252416 (diff)
downloadgentoo-2-bc2b505dfabdca3f899c28bbb8e8490484ff68e0.tar.gz
gentoo-2-bc2b505dfabdca3f899c28bbb8e8490484ff68e0.tar.bz2
gentoo-2-bc2b505dfabdca3f899c28bbb8e8490484ff68e0.zip
Fixed bug #268089
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'net-im/qtwitter')
-rw-r--r--net-im/qtwitter/ChangeLog8
-rw-r--r--net-im/qtwitter/qtwitter-0.6.0-r2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index bd270e6a78d9..cf2358bf59a0 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.1 2009/04/30 16:49:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.2 2009/05/01 15:06:47 hwoarang Exp $
+
+*qtwitter-0.6.0-r2 (01 May 2009)
+
+ 01 May 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qtwitter-0.6.0-r2.ebuild:
+ Fixed bug #268089
*qtwitter-0.6.0-r1 (30 Apr 2009)
diff --git a/net-im/qtwitter/qtwitter-0.6.0-r2.ebuild b/net-im/qtwitter/qtwitter-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..587b77371d89
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.6.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.6.0-r2.ebuild,v 1.1 2009/05/01 15:06:47 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4 multilib
+
+DESCRIPTION="A Qt client for Twitter"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/current/src/${P}-r1-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+ sed -i "s/\$\${INSTALL_PREFIX}\/lib/\$\${INSTALL_PREFIX}\/$(get_libdir)/" \
+ twitterapi/twitterapi.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README || die "dodoc failed"
+}