summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-10 04:05:05 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-10 04:05:05 +0000
commitea6607ea90ae7d5be85cbb0a877da07f9ef1838a (patch)
tree671a1a8db49cab4adebc96a8384fb522f6dfc8b2 /net-firewall/iptables
parentAdd fixes from upstream for grep regexp ranges #311885 by Martin von Gagern a... (diff)
downloadgentoo-2-ea6607ea90ae7d5be85cbb0a877da07f9ef1838a.tar.gz
gentoo-2-ea6607ea90ae7d5be85cbb0a877da07f9ef1838a.tar.bz2
gentoo-2-ea6607ea90ae7d5be85cbb0a877da07f9ef1838a.zip
Install ip6tables-apply symlink to iptables-apply #316369 by Paul Tobias and add USE=netlink to control libnfnetlink depend #351880 by Mike Gilbert.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog9
-rw-r--r--net-firewall/iptables/iptables-1.4.10-r1.ebuild75
-rw-r--r--net-firewall/iptables/metadata.xml3
3 files changed, 86 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index ccce6195e78d..218e77f4d62a 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.235 2011/01/13 18:56:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.236 2011/02/10 04:05:05 vapier Exp $
+
+*iptables-1.4.10-r1 (10 Feb 2011)
+
+ 10 Feb 2011; Mike Frysinger <vapier@gentoo.org> +iptables-1.4.10-r1.ebuild,
+ metadata.xml:
+ Install ip6tables-apply symlink to iptables-apply #316369 by Paul Tobias and
+ add USE=netlink to control libnfnetlink depend #351880 by Mike Gilbert.
13 Jan 2011; Brent Baude <ranger@gentoo.org> iptables-1.4.10.ebuild:
stable ppc, bug 347179
diff --git a/net-firewall/iptables/iptables-1.4.10-r1.ebuild b/net-firewall/iptables/iptables-1.4.10-r1.ebuild
new file mode 100644
index 000000000000..276b4f243cef
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.10-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.10-r1.ebuild,v 1.1 2011/02/10 04:05:05 vapier Exp $
+
+EAPI="2"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 netlink"
+
+DEPEND="virtual/os-headers"
+RDEPEND="netlink? ( net-libs/libnfnetlink )"
+
+src_prepare() {
+ # Only run autotools if user patched something
+ epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+ sed -i \
+ -e "/nfnetlink=[01]/s:=[01]:=$(use netlink && echo 1 || echo 0):" \
+ configure
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doman iptables-apply.8 || die
+ dodoc INCOMPATIBILITIES iptables.xslt || die
+
+ # all the iptables binaries are in /sbin, so might as well
+ # put these small files in with them
+ into /
+ dosbin iptables-apply || die
+ dosym iptables-apply /sbin/ip6tables-apply || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+
+ # Move important libs to /lib
+ gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
diff --git a/net-firewall/iptables/metadata.xml b/net-firewall/iptables/metadata.xml
index 6d895815e0c5..80a5598c8e6a 100644
--- a/net-firewall/iptables/metadata.xml
+++ b/net-firewall/iptables/metadata.xml
@@ -5,6 +5,9 @@
<maintainer>
<email>pva@gentoo.org</email>
</maintainer>
+<use>
+ <flag name='netlink'>Build against libnfnetlink which enables the nfnl_osf util</flag>
+</use>
<longdescription>
iptables is the userspace command line program used to set up, maintain, and
inspect the tables of IPv4 packet filter rules in the Linux kernel. It's a