summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-04 14:17:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-04 14:17:14 +0000
commit298710731915d7f1aa61727b9156c65445bb96f6 (patch)
treeeb9c459a18297c05be8e81b1255ef85700afa0dc /net-dns
parentAdd ~mips keywords to qt-4.4.2 (diff)
downloadgentoo-2-298710731915d7f1aa61727b9156c65445bb96f6.tar.gz
gentoo-2-298710731915d7f1aa61727b9156c65445bb96f6.tar.bz2
gentoo-2-298710731915d7f1aa61727b9156c65445bb96f6.zip
Bump to 3.8.0, fixes #257200
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ddclient/ChangeLog9
-rw-r--r--net-dns/ddclient/ddclient-3.8.0.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/net-dns/ddclient/ChangeLog b/net-dns/ddclient/ChangeLog
index fcb5f368a7ac..3a40c76598c7 100644
--- a/net-dns/ddclient/ChangeLog
+++ b/net-dns/ddclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ddclient
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.37 2008/01/21 18:17:50 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ChangeLog,v 1.38 2009/02/04 14:17:14 patrick Exp $
+
+*ddclient-3.8.0 (04 Feb 2009)
+
+ 04 Feb 2009; Patrick Lauer <patrick@gentoo.org> +ddclient-3.8.0.ebuild:
+ Bump to 3.8.0, fixes #257200
21 Jan 2008; Raúl Porcel <armin76@gentoo.org> -files/ddclient.init,
-files/ddclient.rc6, -files/ddclient-daemon0inconfig.diff,
diff --git a/net-dns/ddclient/ddclient-3.8.0.ebuild b/net-dns/ddclient/ddclient-3.8.0.ebuild
new file mode 100644
index 000000000000..bea07e603c09
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.8.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ddclient/ddclient-3.8.0.ebuild,v 1.1 2009/02/04 14:17:14 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Perl updater client for dynamic DNS services"
+HOMEPAGE="http://ddclient.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+
+RDEPEND=">=dev-lang/perl-5.1
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-reasonable-security.patch"
+
+ einfo "Applying version string fix"
+ if ! sed -i "s/3\.7\.1/$PV/" "$PN"; then
+ eerror "Failed to update ddclient's internal version string"
+ eerror 'ddclient 3.7.2 will erroneously report a version of 3.7.1'
+ fi
+
+ # Remove pid line, because it is specified in /etc/conf.d/ddclient
+ einfo "Applying PID setup"
+ if ! sed -i "/^pid=*/d" "sample-etc_${PN}.conf"; then
+ eerror "Failed to remove pid from /etc/$PN/$PN.conf"
+ eerror "Please set the PID in /etc/conf.d/$PN, not /etc/$PN/$PN.conf"
+ fi
+
+ if ! use ssl; then
+ einfo "Disabling ssl per your useflags"
+ sed -i "/^ssl=*/d" "sample-etc_${PN}.conf" ||
+ eerror "Failed to remove ssl from /etc/$PN/$PN.conf"
+ fi
+}
+
+src_install() {
+ dosbin ${PN} || die "dosbin failed"
+ dodoc README* Change* COPYRIGHT sample*
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/{cache,run}/${PN}
+
+ # Filename of sample conf - use live filename if available
+ local sample=${PN}.conf
+ [[ -e "${ROOT}/etc/${PN}/${sample}" ]] && sample="${sample}.sample"
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g ${PN}
+ newins sample-etc_${PN}.conf "${sample}" || die "newins conf failed"
+}
+
+pkg_postinst() {
+ # ensure the directories are owned by the user:group for this pkg
+ chown ${PN}:${PN} /var/{cache,run}/${PN}
+
+ use ssl && return
+ ewarn
+ ewarn "$PN will not have support for ssl, which means your dynamic DNS account"
+ ewarn "information -- including your password -- will be sent over the Internet in the"
+ ewarn "clear. To secure your information, add 'ssl' to your USEflags,"
+ ewarn "emerge -N ddclient, and add 'ssl=yes' to /etc/$PN/$PN.conf"
+ ewarn
+}