summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-17 04:50:51 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-17 04:50:51 +0000
commit42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f (patch)
tree4909112dca2c10b8140cdf52d17bbc5ded926eae /net-dns/pdns/pdns-2.9.18.ebuild
parentAdded new net-dns/pdns flags. (diff)
downloadgentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.tar.gz
gentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.tar.bz2
gentoo-2-42ea8bfae2fddb8c5115dc3ec68f39e7dda5339f.zip
Version bump. Added support for the recursor component, bug #59862. Added multiple instances support, thanks to Christian Zoffoli in bug #80322. Enabled the sqlite backend, bug #91325.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-dns/pdns/pdns-2.9.18.ebuild')
-rw-r--r--net-dns/pdns/pdns-2.9.18.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-dns/pdns/pdns-2.9.18.ebuild b/net-dns/pdns/pdns-2.9.18.ebuild
new file mode 100644
index 000000000000..151fd7bba3e4
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.18.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.18.ebuild,v 1.1 2005/07/17 04:50:51 swegener Exp $
+
+DESCRIPTION="The PowerDNS Daemon"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc ldap mysql postgres recursor sqlite static tdb"
+
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ recursor? ( dev-libs/boost )
+ tdb? ( dev-libs/tdb )"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ local modules="pipe geo" myconf=""
+
+ use mysql && modules="${modules} gmysql"
+ use postgres && modules="${modules} gpgsql"
+ use sqlite && modules="${modules} gsqlite"
+ use ldap && modules="${modules} ldap"
+ use tdb && modules="${modules} xdb"
+ use debug && myconf="${myconf} --enable-verbose-logging"
+
+ econf \
+ --with-modules= \
+ --with-dynmodules="${modules}" \
+ $(use_enable static static-binaries) \
+ $(use_enable recursor) \
+ ${myconf} \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use doc
+ then
+ emake -C codedocs codedocs || die "emake codedocs failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ mv "${D}"/etc/pdns.conf{-dist,}
+ doinitd "${FILESDIR}"/pdns
+
+ if use recursor
+ then
+ doinitd "${FILESDIR}"/precursor
+ insinto /etc
+ doins "${FILESDIR}"/recursor.conf
+ fi
+
+ dodoc ChangeLog README TODO
+ use doc && dohtml -r codedocs/html/.
+}
+
+pkg_postinst() {
+ einfo
+ einfo "pdns now provides multiple instances support. You can create more instances"
+ einfo "by symlinking the pdns init script to another name."
+ einfo
+ einfo "The name must be in the format pdns-<suffix> and PowerDNS will use the"
+ einfo "/etc/pdns-<suffix>.conf configuration file instead of the default."
+ einfo
+ einfo "Also all backends, except the bind and random backends, are now compiled as"
+ einfo "loadable modules and must be loaded with load-modules= in the configuration"
+ einfo "file."
+ einfo
+}