summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-28 05:58:16 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-28 05:58:16 +0000
commit7c0a4ae868229c105c30846313dedcec35934eb1 (patch)
treecf5ebcb8c2d72c0fea6359d017a4a0ac57cef4ed /net-dialup/wvdial/files
parent[media-sound/amarok] Bumped to the 2.3.1 release. (diff)
downloadgentoo-2-7c0a4ae868229c105c30846313dedcec35934eb1.tar.gz
gentoo-2-7c0a4ae868229c105c30846313dedcec35934eb1.tar.bz2
gentoo-2-7c0a4ae868229c105c30846313dedcec35934eb1.zip
Fixed build issue, bug #321729, thank Willard Dawson for report and Samuli Suominen, Lars Wendler (Polynomial-C) for this fix.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/wvdial/files')
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch b/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch
new file mode 100644
index 000000000000..4c0c83709dd0
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch
@@ -0,0 +1,20 @@
+--- wvdial-1.61/wvrules-posix.mk
++++ wvdial-1.61/wvrules-posix.mk
+@@ -85,12 +85,15 @@
+ $(AR) s $1
+ endef
+
+-CC: FORCE
++CC:
+ @CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS_SRC)/gen-cc CC c
+
+-CXX: FORCE
++CXX:
+ @CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS_SRC)/gen-cc CXX cc
+
++#All files must depend on the above two rules. This is a godawful hack.
++$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX
++
+ wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS)